Ole Gunnar Borstad <[EMAIL PROTECTED]> writes: > Derby Developer's Guide states the following: "When Derby is running > in a connectivity server and user authentication is turned on, > stopping the server requires a user name and password. You will need > to alter shutdown scripts accordingly." > > I don't seem to find a command or argument to shutdown the network > server when authentication is enabled in Derby...?
You are right. Currently, only shutting down an individual database is protected. Shutting down the server will be protected when DERBY-2109 (system privileges) is in place. I agree the error message is confusing. Dag > > I did a simple java -jar derbynet.jar shutdown and the server prints > the following: > > Derby shutdown warning: > Connection refused : Invalid authentication. > Apache Derby Network Server - 10.4.0.0 alpha - (554547M) shutdown at > 2007-07-25 12:31:08.948 GMT > > So did the server shut down properly or not? > >
