On Wed, 2016-09-21 at 16:14 +0200, Tobias Mueller wrote:
> Try LDFLAGS+=-lasan

==21260==ASan runtime does not come first in initial library list; you
should either link runtime to your application or manually preload it
with LD_PRELOAD.

> Another source of inconvenience is when compiling any library that
> GCC needs itself, like gnome-calculator does.
> Then, setting LD_PRELOAD=/usr/lib64/libasan.so worked for me.

For some reason, Fedora doesn't seem to have a libasan-devel package,
so there's no plain libasan.so. Really strange. I tried changing it to
libasan.so.3 in my jhbuildrc but actually couldn't figure out how to do
that; jhbuild is playing with LD_PRELOAD as well. :(

Michael
_______________________________________________
desktop-devel-list mailing list
desktop-devel-list@gnome.org
https://mail.gnome.org/mailman/listinfo/desktop-devel-list

Reply via email to