Hi.

On Mi, 2016-09-21 at 11:27 -0500, Michael Catanzaro wrote:
> > Then, setting LD_PRELOAD=/usr/lib64/libasan.so worked for me.
> 
> For some reason, Fedora doesn't seem to have a libasan-devel package,
hm. On my system, I have:

$ dpkg -S /usr/lib/gcc/x86_64-linux-gnu/5/libasan.so
libgcc-5-dev:amd64: /usr/lib/gcc/x86_64-linux-gnu/5/libasan.so

$ dpkg -S /usr/lib/x86_64-linux-gnu/libasan.so.2
libasan2:amd64: /usr/lib/x86_64-linux-gnu/libasan.so.2

> so there's no plain libasan.so. Really strange. I tried changing it to
> libasan.so.3 in my jhbuildrc but actually couldn't figure out how to do
> that; jhbuild is playing with LD_PRELOAD as well. :(
I know little about jhbuild.  I think you could try to jhbuild shell
into your environment, look at $LD_PRELOAD, prefix it with the path to
libasan, and then do "make" or whatever command it intended to execute.
If that works, it needs to be made nicer, though.

Another option altogether may be to statically link ASan with
-static-asan.  I haven't tried that yet, however. I also don't know how
well it actually works in the particular case of ld_opened libraries
that you are describing.

Cheers,
  Tobi

Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
desktop-devel-list mailing list
desktop-devel-list@gnome.org
https://mail.gnome.org/mailman/listinfo/desktop-devel-list

Reply via email to