I don't know why my attachments were removed, but this issue was fixed
by upgrading the kernel to http://kernel.ubuntu.com/~kernel-
ppa/mainline/v4.8-rc6/

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1581560

Title:
  system crash when attaching external display

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  After upgrading to 16.04, my thinkpad x1 carbon (3rd edition) freezes
  and reboots when I attach an external display.

  Process: 
  -  put laptop to sleep.
  - come into work the next day
  - open up laptop
  - plug in external display
  - observe bug

  Expected behavior: I can attach the external display
  Observed behavior: system shows black screen on both laptop and display and 
after a minute or two reboots.  Laptop drives external display fine after 
reboot.

  I ssh to the laptop from another machine and monitored
  /var/log/syslog, /var/log/Xorg.0.log, and ~/.xsession-errors.  All I
  see in those files before the lockup is this, from Xorg.0.log:

  [ 34289.447] (II) intel(0): Enabled output DP1-8
  [ 34289.448] (II) intel(0): Enabled output DP1-1
  [ 34289.460] (II) intel(0): resizing framebuffer to 2560x1440
  [ 34289.482] (II) intel(0): switch to mode 2560x1440@60.0 on DP1-8 using pipe 
0,
  (0, 0), rotation normal, reflection none

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CompizPlugins: 
[core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Fri May 13 09:24:07 2016
  DistUpgraded: 2016-04-21 20:51:13,846 ERROR got error from PostInstallScript 
./xorg_fix_proprietary.py (g-exec-error-quark: Failed to execute child process 
"./xorg_fix_proprietary.py" (No such file or directory) (8))
  DistroCodename: xenial
  DistroVariant: ubuntu
  DkmsStatus:
   virtualbox, 5.0.18, 4.2.0-30-generic, x86_64: installed
   virtualbox, 5.0.18, 4.4.0-21-generic, x86_64: installed
   virtualbox, 5.0.18, 4.4.0-22-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) 
(prog-if 00 [VGA controller])
     Subsystem: Lenovo Broadwell-U Integrated Graphics [17aa:2227]
  InstallationDate: Installed on 2015-09-10 (245 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  MachineType: LENOVO 20BS0031US
  ProcEnviron:
   LANGUAGE=en_US:en
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_US.UTF-8
   SHELL=/bin/zsh
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-22-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to xenial on 2016-04-22 (21 days ago)
  dmi.bios.date: 05/08/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N14ET29W (1.07 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20BS0031US
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0E50510 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN14ET29W(1.07):bd05/08/2015:svnLENOVO:pn20BS0031US:pvrThinkPadX1Carbon3rd:rvnLENOVO:rn20BS0031US:rvrSDK0E50510WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.name: 20BS0031US
  dmi.product.version: ThinkPad X1 Carbon 3rd
  dmi.sys.vendor: LENOVO
  drirc:
   
  version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.67-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2
  xserver.bootTime: Fri May 13 09:04:56 2016
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id                                4669 
   vendor                                     AUO
  xserver.version: 2:1.18.3-1ubuntu2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1581560/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to