P.S. Also not forget to remove HPLIP before trying Fumatic.

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1748723

Title:
  HP Laserjet1018 detected by 17.10 but not print anything

Status in cups package in Ubuntu:
  New

Bug description:
  Cuos and HPLIB are installed but HP-Check show errors
  The Printer HP Laserjet1018 has been detected by Ubuntu 17.01 an is defined 
as standard printer
  I can start a print request, it goes in the print queue and finished without 
printing.
  On Ubuntu 16.04 everything works fine after install HPLIP

  See same in attachment THANKS

  cyborg2058@cyborg2058-Z370-HD3P:~$ hp-check
  Saving output in log file: /home/cyborg2058/hp-check.log

  HP Linux Imaging and Printing System (ver. 3.17.7)
  Dependency/Version Check Utility ver. 15.1

  Copyright (c) 2001-15 HP Development Company, LP
  This software comes with ABSOLUTELY NO WARRANTY.
  This is free software, and you are welcome to distribute it
  under certain conditions. See COPYING file for more details.

  Note: hp-check can be run in three modes:
  1. Compile-time check mode (-c or --compile): Use this mode before compiling 
the
  HPLIP supplied tarball (.tar.gz or .run) to determine if the proper 
dependencies
  are installed to successfully compile HPLIP.                                  
  
  2. Run-time check mode (-r or --run): Use this mode to determine if a distro  
  
  supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball 
  
  has the proper dependencies installed to successfully run.                    
  
  3. Both compile- and run-time check mode (-b or --both) (Default): This mode  
  
  will check both of the above cases (both compile- and run-time dependencies). 
  

  Check types:                                                                  
  
  a. EXTERNALDEP - External Dependencies                                        
  
  b. GENERALDEP - General Dependencies (required both at compile and run time)  
  
  c. COMPILEDEP - Compile time Dependencies                                     
  
  d. [All are run-time checks]                                                  
  
  PYEXT SCANCONF QUEUES PERMISSION                                              
  

  Status Types:
      OK
      MISSING       - Missing Dependency or Permission or Plug-in
      INCOMPAT      - Incompatible dependency-version or Plugin-version

  warning: 12-17.10 version is not supported. Using 12-17.04 versions
  dependencies to verify and install...

  ---------------
  | SYSTEM INFO |
  ---------------

   Kernel: 4.13.0-32-generic #35-Ubuntu SMP Thu Jan 25 09:13:46 UTC 2018 
GNU/Linux
   Host: cyborg2058-Z370-HD3P
   Proc: 4.13.0-32-generic #35-Ubuntu SMP Thu Jan 25 09:13:46 UTC 2018 GNU/Linux
   Distribution: 12 17.10
   Bitness: 64 bit

  
  -----------------------
  | HPLIP CONFIGURATION |
  -----------------------

  HPLIP-Version: HPLIP 3.17.7
  HPLIP-Home: /usr/share/hplip
  warning: HPLIP-Installation: Auto installation is not supported for 12 distro 
 17.10 version 

  Current contents of '/etc/hp/hplip.conf' file:
  # hplip.conf.  Generated from hplip.conf.in by configure.

  [hplip]
  version=3.17.7

  [dirs]
  home=/usr/share/hplip
  run=/var/run
  ppd=/usr/share/ppd/hplip/HP
  ppdbase=/usr/share/ppd/hplip
  doc=/usr/share/doc/hplip
  html=/usr/share/doc/hplip-doc
  icon=no
  cupsbackend=/usr/lib/cups/backend
  cupsfilter=/usr/lib/cups/filter
  drv=/usr/share/cups/drv
  bin=/usr/bin
  apparmor=/etc/apparmor.d
  # Following values are determined at configure time and cannot be changed.
  [configure]
  network-build=yes
  libusb01-build=no
  pp-build=yes
  gui-build=yes
  scanner-build=yes
  fax-build=yes
  dbus-build=yes
  cups11-build=no
  doc-build=yes
  shadow-build=no
  hpijs-install=yes
  foomatic-drv-install=yes
  foomatic-ppd-install=yes
  foomatic-rip-hplip-install=no
  hpcups-install=yes
  cups-drv-install=yes
  cups-ppd-install=no
  internal-tag=3.17.7
  restricted-build=no
  ui-toolkit=qt5
  qt3=no
  qt4=no
  qt5=yes
  policy-kit=yes
  lite-build=no
  udev_sysfs_rules=no
  hpcups-only-build=no
  hpijs-only-build=no
  apparmor_build=no

  
  Current contents of '/var/lib/hp/hplip.state' file:
  Plugins are not installed. Could not access file: No such file or directory

  Current contents of '~/.hplip/hplip.conf' file:
  [installation]
  date_time = 02/11/18 10:25:05
  version = 3.17.7

  
   <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> 
<Installed-Version> <Status>   <Comment>

  -------------------------
  | External Dependencies |
  -------------------------

   error: cups          CUPS - Common Unix Printing System                      
     REQUIRED        1.1             -               INCOMPAT   'CUPS may not 
be installed or not running'
   gs                   GhostScript - PostScript and PDF language interpreter 
and previewer REQUIRED        7.05            9.21            OK         -
   error: xsane         xsane - Graphical scanner frontend for SANE             
     OPTIONAL        0.9             -               MISSING    'xsane needs to 
be installed'
   scanimage            scanimage - Shell scanning program                      
     OPTIONAL        1.0             1.0.27          OK         -
   error: dbus          DBus - Message bus system                               
     REQUIRED        -               1.10.22         MISSING    'DBUS may not 
be installed or not running'
   policykit            PolicyKit - Administrative policy framework             
     OPTIONAL        -               0.105           OK         -
   network              network -wget                                           
     OPTIONAL        -               1.19.1          OK         -
   avahi-utils          avahi-utils                                             
     OPTIONAL        -               0.6.32          OK         -

  ------------------------
  | General Dependencies |
  ------------------------

   error: libjpeg       libjpeg - JPEG library                                  
     REQUIRED        -               -               MISSING    'libjpeg needs 
to be installed'
   error: cups-devel    CUPS devel- Common Unix Printing System development 
files    REQUIRED        -               -               MISSING    'cups-devel 
needs to be installed'
   error: cups-image    CUPS image - CUPS image development files               
     REQUIRED        -               -               MISSING    'cups-image 
needs to be installed'
   error: libpthread    libpthread - POSIX threads library                      
     REQUIRED        -               b'2.26'         MISSING    'libpthread 
needs to be installed'
   error: libusb        libusb - USB library                                    
     REQUIRED        -               1.0             MISSING    'libusb needs 
to be installed'
   sane                 SANE - Scanning library                                 
     REQUIRED        -               -               OK         -
   error: sane-devel    SANE - Scanning library development files               
     REQUIRED        -               -               MISSING    'sane-devel 
needs to be installed'
   error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library 
development files REQUIRED        5.0.9           -               MISSING    
'libnetsnmp-devel needs to be installed'
   error: libcrypto     libcrypto - OpenSSL cryptographic library               
     REQUIRED        -               1.0.2           MISSING    'libcrypto 
needs to be installed'
   python3X             Python 2.2 or greater - Python programming language     
     REQUIRED        2.2             3.6.3           OK         -
   error: python3-notify2 Python libnotify - Python bindings for the libnotify 
Desktop notifications OPTIONAL        -               -               MISSING   
 'python3-notify2 needs to be installed'
   error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4               
          OPTIONAL        4.0             -               MISSING    
'python3-pyqt4-dbus needs to be installed'
   error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)    
     REQUIRED        4.0             -               MISSING    'python3-pyqt4 
needs to be installed'
   python3-dbus         Python DBus - Python bindings for DBus                  
     REQUIRED        0.80.0          1.2.4           OK         -
   python3-xml          Python XML libraries                                    
     REQUIRED        -               2.2.3           OK         -
   error: python3-devel Python devel - Python development files                 
     REQUIRED        2.2             3.6.3           MISSING    'python3-devel 
needs to be installed'
   python3-pil          PIL - Python Imaging Library (required for commandline 
scanning with hp-scan) OPTIONAL        -               1.1.7           OK       
  -
   python3-reportlab    Reportlab - PDF library for Python                      
     OPTIONAL        2.0             3.4.0           OK         -

  --------------
  | COMPILEDEP |
  --------------

   error: libtool       libtool - Library building support services             
     REQUIRED        -               -               MISSING    'libtool needs 
to be installed'
   error: gcc           gcc - GNU Project C and C++ Compiler                    
     REQUIRED        -               -               MISSING    'gcc needs to 
be installed'
   error: make          make - GNU make utility to maintain groups of programs  
     REQUIRED        3.0             -               MISSING    'make needs to 
be installed'

  ---------------------
  | Python Extentions |
  ---------------------

   cupsext              CUPS-Extension                                          
     REQUIRED        -               3.17.7          OK         -
   hpmudext             IO-Extension                                            
     REQUIRED        -               3.17.7          OK         -

  ----------------------
  | Scan Configuration |
  ----------------------

  '/etc/sane.d/dll.d/hpaio' not found.
   hpaio                HPLIP-SANE-Backend                                      
     REQUIRED        -               3.17.7          OK         'hpaio found in 
/etc/sane.d/dll.conf'
   scanext              Scan-SANE-Extension                                     
     REQUIRED        -               3.17.7          OK         -

  ------------------------------
  | DISCOVERED SCANNER DEVICES |
  ------------------------------

  No Scanner found.

  --------------------------
  | DISCOVERED USB DEVICES |
  --------------------------

  No devices found.

  ---------------------------------
  | INSTALLED CUPS PRINTER QUEUES |
  ---------------------------------

   
  HP-LaserJet-1018
  ----------------
  Type: Printer
  Device URI: hp:/usb/HP_LaserJet_1018?serial=KP0T4XH
  PPD: /etc/cups/ppd/HP-LaserJet-1018.ppd
  warning: Failed to read /etc/cups/ppd/HP-LaserJet-1018.ppd ppd file
  PPD Description: 
  Printer status: Drucker HP-LaserJet-1018 ist im Leerlauf.  Aktiviert seit Sam 
10 Feb 2018 19:14:20 CET
  error: Required plug-in status: Not installed
  error: Unable to communicate with device (code=12): 
hp:/usb/HP_LaserJet_1018?serial=KP0T4XH
  error: Device not found
  error: Communication status: Failed

  
  --------------
  | PERMISSION |
  --------------

   
  -----------
  | SUMMARY |
  -----------

  Missing Required Dependencies
  -----------------------------
  error: 'libcups2' package is missing/incompatible 
  error: 'libdbus-1-dev' package is missing/incompatible 
  error: 'libjpeg-dev' package is missing/incompatible 
  error: 'libcups2-dev' package is missing/incompatible 
  error: 'cups-bsd' package is missing/incompatible 
  error: 'cups-client' package is missing/incompatible 
  error: 'libcupsimage2-dev' package is missing/incompatible 
  error: 'build-essential' package is missing/incompatible 
  error: 'libusb-1.0.0-dev' package is missing/incompatible 
  error: 'libsane-dev' package is missing/incompatible 
  error: 'libsnmp-dev' package is missing/incompatible 
  error: 'snmp-mibs-downloader' package is missing/incompatible 
  error: 'openssl' package is missing/incompatible 
  error: 'python3-pyqt4' package is missing/incompatible 
  error: 'gtk2-engines-pixbuf' package is missing/incompatible 
  error: 'python3-dev' package is missing/incompatible 
  error: 'libtool' package is missing/incompatible 
  error: 'libtool-bin' package is missing/incompatible 
  error: 'build-essential' package is missing/incompatible 
  error: 'build-essential' package is missing/incompatible 

  Missing Optional Dependencies
  -----------------------------
  error: 'gtk2-engines-pixbuf' package is missing/incompatible 
  error: 'xsane' package is missing/incompatible 
  error: 'python3-notify2' package is missing/incompatible 
  error: 'python3-dbus.mainloop.qt' package is missing/incompatible 

  Plug-in Status
  --------------
  error: Plug-ins need to be installed

  Total Errors: 20
  Total Warnings: 0

  
  Done.

  cyborg2058@cyborg2058-Z370-HD3P:~$ sudo apt-get install cups cups-client 
cups-bsd 
  [sudo] Passwort für cyborg2058: 
  Paketlisten werden gelesen... Fertig
  Abhängigkeitsbaum wird aufgebaut.       
  Statusinformationen werden eingelesen.... Fertig
  cups ist schon die neueste Version (2.2.4-7ubuntu3).
  cups-bsd ist schon die neueste Version (2.2.4-7ubuntu3).
  cups-client ist schon die neueste Version (2.2.4-7ubuntu3).
  0 aktualisiert, 0 neu installiert, 0 zu entfernen und 2 nicht aktualisiert.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1748723/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to