I have noticed the same thing. I am running on 16.04 with the HWE 17.10 kernel 
and monitor works.
I installed the bionic 4.14.0-17 kernel and I was able to still use the laptop 
display. I tried the latest Bionic kernel (4.15.0-13) and it does not work.
During testing on another bug (LP:1738263) I tested Artful with the Bionic 
kernel 4.15.0-10 and everything appeared to be working normally with the 
exception that DKMS failed to build the NVIDIA modules due to not being 
compatible with the the header files. However, when you install anything newer, 
the display fails to stay on past the GRUB menu.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xserver-xorg-video-nouveau in Ubuntu.

  nouveau/nvidia drivers do not work with display in Bionic on Asus
  GL703VD Laptop

Status in nvidia-graphics-drivers-390 package in Ubuntu:
Status in xserver-xorg-video-nouveau package in Ubuntu:

Bug description:
  Tried to install Bionic Desktop on my Asus GL703VD ROG Laptop with
  NVIDIA GTX 1050M Video Card (with i915 Intel graphics card when not
  using 3D) and the installer does not display. I have tried
  nouveau.modeset=0 and nomodeset boot options to no avail. I was able
  to finally install Bionic by hooking up the laptop to a projector, but
  after a reboot, the laptop display still did not work and I had to set
  the account to autologin otherwise I could not login to the laptop. I
  then install openssh-server so that I could ssh into the laptop and I
  installed the nvidia-390 drivers from ppa:graphics-drivers/ppa which
  installed, but still no local display.

  In Artful, I could install with the nouveau.modeset=0 and then
  installing the proprietary NVIDIA drivers and everything (except
  touchpad, LP: 1738263) worked.

  lspci shows the graphics card and NVIDIA card, and lsmod does show
  that before NVIDIA drivers install, it is using nouveau, asus_wmi, and
  i915 for graphcis, and once NVIDIA drivers are install, lsmod only
  shows i915 and asus_wmi for graphics while nvidia is used for gpu and
  3D, but still no display on the laptop.

  lsmod_prenvidia.txt shows the nouveau driver and the /proc/cmdline
  lsmod_nvidia.txt shows nvidia drivers installed and the /proc/cmdline
  lspci.txt shows the detected hardware
  lshw.txt shows the hardware in the laptop.

  Please let me know if you need any other information.


To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to