It sounds like some part of the system has crashed. Please:

1. Apply the workaround from bug 994921.

2. Look in /var/crash for crash files and if found run:
     ubuntu-bug YOURFILE.crash
   and tell us the ID of the newly-created bug.

3. If step 2 failed then look at https://errors.ubuntu.com/user/ID where
ID is the contents of the /var/lib/whoopsie/whoopsie-id file on the
machine. Do you find any links to recent problems on the machine? If so
then please send them to us.


** Package changed: xorg (Ubuntu) => xorg-server (Ubuntu)

** Changed in: xorg-server (Ubuntu)
       Status: New => Incomplete

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg-server in Ubuntu.
https://bugs.launchpad.net/bugs/1781154

Title:
  Xorg session reset on suspend / wake-up

Status in xorg-server package in Ubuntu:
  Incomplete

Bug description:
  My preconditions:
  - running Chromium + Thunderbird on workspace 1
  - running 2x Eclipse + Notepad on workspace 2 - active workspace
  - using internal laptop screen
  - using Gnome desktop with dynamic workspaces

  How I reproduce (with almost 100% success):
  - Suspend (using suspend button from system menu)
  - connect external monitors to Display-Port (primary) and SVGA (secondary); 
internal laptop screen is disabled in this configuration (saved)
  - wake-up

  Current result:
  - Xorg session is re-started and *no* applications from previous session are 
running.

  Expected result:
  - System resumes where it was before with all applications continuing from 
where they were on suspend.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.15.0-24.26~16.04.1-generic 4.15.18
  Uname: Linux 4.15.0-24-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  .proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/0000:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  396.24.02  Thu May 24 
03:48:07 PDT 2018
   GCC version:  gcc version 7.3.0 (Ubuntu 7.3.0-21ubuntu1~16.04)
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2.18
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: GNOME
  Date: Wed Jul 11 09:56:12 2018
  DistUpgraded: Fresh install
  DistroCodename: xenial
  DistroVariant: ubuntu
  EcryptfsInUse: Yes
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation GK107GLM [Quadro K2000M] [10de:0ffb] (rev a1) (prog-if 00 
[VGA controller])
     Subsystem: Lenovo GK107GLM [Quadro K2000M] [17aa:21f6]
  MachineType: LENOVO 244759G
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-24-generic 
root=UUID=cf56f770-2527-47cc-bf3b-a1815c6c2a09 ro quiet splash acpi_osi=Linux 
acpi_backlight=none vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/24/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G5ETA6WW (2.66 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 244759G
  dmi.board.vendor: LENOVO
  dmi.board.version: Win8 Pro DPK TPG
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvrG5ETA6WW(2.66):bd08/24/2016:svnLENOVO:pn244759G:pvrThinkPadW530:rvnLENOVO:rn244759G:rvrWin8ProDPKTPG:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad W530
  dmi.product.name: 244759G
  dmi.product.version: ThinkPad W530
  dmi.sys.vendor: LENOVO
  version.compiz: compiz 1:0.9.12.3+16.04.20180221-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.91-2~16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~16.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~16.04.1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core N/A
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
  xserver.bootTime: Wed Jul 11 09:54:47 2018
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   
  xserver.version: 2:1.19.6-1ubuntu4~16.04.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1781154/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to