Hi all,

why do the meta-packages require a lot of optional stuff e.g. (demodata, 
amazon-pay-sdk, amazonpay4oxid, payone, …)?

From a perspective of an EE user, it is not really handy to build a custom 
composer.json with all the OXID components along the whole hierarchy and 
dependencies (metapackage-ee -> metapackage-pe -> metapackage-ce) and keep them 
up to date with every new release, for just moving out the stuff which will 
never be used, like the assets in the out directory from the demo-data packages.

I would really appreciate if the meta-packages from OXID could be clean 
packages and all the other optional stuff will be moved to the suggested 
section in the composer.json (https://getcomposer.org/doc/04-schema.md#suggest) 
because they are also not required in this term for a runnable OXID eShop. The 
user is then informed which packages could be installed optionally and can 
decide to require these (demodata, amazon-pay-sdk, amazonpay4oxid, payone, …) 
or not.

Example composer output could then be:
oxid-esales/oxideshop-metapackage-ce suggests installing 
oxid-esales/oxideshop-demodata-ce (OXID eShop demo data for the CE edition)

What do you think?

Thanks,
Jens-Christopher Trant


[Closed]<http://www.closed.com/>


Closed GmbH  |  Straßenbahnring 6  |  20251 Hamburg  |  Germany
T +49 40 441840 865  |  M +49 151 28439981  |  E 
jens.tr...@closed.com<mailto:jens.tr...@closed.com>
closed.com<http://closed.com>  |  
facebook.com/closed<https://www.facebook.com/closed> 
<http://www.facebook.com/closed>  |  instagram.com/closedofficial 
<https://www.instagram.com/closedofficial/>

Amtsgericht Hamburg HRB 53868 | Umsatzsteuer-Ident.-Nr.: DE 164980577
GF: Gordon Giers, Til Nadler, Hans Redlefsen

Reply via email to