Github user clebertsuconic commented on a diff in the pull request:
@@ -25,4 +25,6 @@
void addFactory(ProtocolManagerFactory<Interceptor> pmf);
void removeFactory(ProtocolManagerFactory<Interceptor> pmf);
+ void setDataSourceDependency(boolean dataSourceDependency);
--- End diff --
what about renaming this to:
the callback could then decide what to do.
the best would be to have a class extending ProtocolTrackerCallback:
ServerTrackerCallback extends ProtocolTrackerCallback
And at the caller we would check an instanceof.
Would that be possible with OSGI?
BTW: thanks for rebasing... at least I can comment on these changes now.
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastruct...@apache.org or file a JIRA ticket