Are you able to browse the artifact in UI? Can you check if the artifact is 
properly saved in your file-system
D:\platform\tools\apache-archiva-2.2.1\repositories\snapshots or

Thanks & regards
Harish Mangala
Staff Software Engineer | Emp-id: 1633
CTO Office | Altimetrik India Pvt. Ltd.
Electronic city phase II, Hosur Road, Bangalore 560100
1st Floor | Mobile: +91 953 89 94 509 | Email:<>
7 Switch off as you go |q Recycle always |  P Go Green.Don't print this e-mail 
unless really needed

From: Arunan Ramanathan
Sent: 20 September 2016 12:23
Cc: Natarajan Veerappan; Harish Mangala
Subject: Reg : Search API always returns 204:No content


I am trying to use the Apache Archiva Rest API for Search. I have a local setup 
in my machine, the following is the URL I am using,


Along with the "Authorization" header with "basic <base64 encoded 
username:pass>" but it is always showing 204:No content

Even I tried to search manually in the UI, it is not returning any result.

The following is my requirement,

1.       I am storing rar file as artifact

2.       No pom files generated

I even checked the repository scanning, even I triggered the scanning for a 
couple of times, still no use. Please help me out.

Thanks & Regards,

Reply via email to