Hi,

yes, I have set the two variables to MANAGE solr and hbase locally, which
makes the atlas_start.py script also start those services.
But this doesn't help.
Don't we need to use solr5 rather than solr as well as the
atlas.graph.index.search.backend ??

Should
"echo 
atlas.graphdb.backend=org.apache.atlas.repository.graphdb.titan0.Titan0GraphDatabase
>> ${ATLAS_HOME}/conf/atlas-application.properties"
be used for the 1.0.0-alpha version?

Thanks a lot in advance!

Regards,
David

2018-02-14 14:55 GMT+01:00 Graham Wallis <graham_wal...@uk.ibm.com>:

> Hi Ernie
>
> As Peter says in his email, there are a couple of environment variables
> needed:
>
> I build the same as you, i.e.:
>
> mvn clean install -DskipTests -Pdist,embedded-hbase-solr
>
> Then I do the following (I am on Windows):
>
> set MANAGE_LOCAL_HBASE=true
>
> set MANAGE_LOCAL_SOLR=true
>
> set
> ATLAS_HOME=c:\dev\atlas\atlas\distro\target\apache-atlas-1.
> 0.0-SNAPSHOT-bin\apache-atlas-1.0.0-SNAPSHOT
>
> cd %ATLAS_HOME%
>
> cd bin
>
> atlas_start.py
>
> ### This will take a long time - several minutes - to claim that the
> server is started.....
>
> ### A further a long time (several minutes) after Atlas claims to have
> started,  I can see the Atlas console in the browser (@localhost:21000)
>
> ### It is possible to now run quick_start...
>
> quick_start.py
>
>
> Best regards,
>   Graham
>
> Graham Wallis
> IBM Analytics Emerging Technology Center
> Internet: graham_wal...@uk.ibm.com
> IBM Laboratories, Hursley Park, Hursley, Hampshire SO21 2JN
> Tel: +44-1962-815356    Tie: 7-245356
>
>
>
>
> From:   "Ernie Ostic" <eos...@us.ibm.com>
> To:     dev@atlas.apache.org
> Date:   14/02/2018 13:47
> Subject:        Re: Server appears to start, but connections fail with 503
>
>
>
> ....the doc implies that if you use embedded, there is nothing special to
> set (unless you want to override the defaults)...
>
> Ernie
>
>
>
>
> Ernie Ostic
>
> Worldwide Technical Sales
> InfoSphere Information Server
> IBM Analytics
>
> Cell: (617) 331 8238
> ---------------------------------------------------------------
> Apache Atlas Update!
> https://dsrealtime.wordpress.com/2017/11/16/apache-atlas-
> update-have-you-been-watching/
>
>
> Open IGC is here!
> https://dsrealtime.wordpress.com/2015/07/29/open-igc-is-here/
>
> David Aspegren ---02/14/2018 08:40:19 AM---Hi, I have the same issue.
> Where are those environment variables for embedded
>
> From: David Aspegren <david.aspeg...@gmail.com>
> To: dev@atlas.apache.org
> Date: 02/14/2018 08:40 AM
> Subject: Re: Server appears to start, but connections fail with 503
>
>
>
> Hi,
>
> I have the same issue. Where are those environment variables for embedded
> hbase described?
>
> regards,
> David
>
> 2018-02-14 14:32 GMT+01:00 Ernie Ostic <eos...@us.ibm.com>:
>
> > Thanks David...
> >
> > build string I am using is: *mvn clean -DskipTests package
> > -Pdist,embedded-hbase-solr*
> >
> > Will check again the environment variables....thx.
> >
> > Ernie
> >
> >
> >
> >
> >
> > Ernie Ostic
> >
> > Worldwide Technical Sales
> > InfoSphere Information Server
> > IBM Analytics
> >
> > Cell: (617) 331 8238 <(617)%20331-8238>
> > ---------------------------------------------------------------
> > Apache Atlas Update!
> https://urldefense.proofpoint.com/v2/url?u=https-3A__
> dsrealtime.wordpress&d=DwIBaQ&c=jf_iaSHvJObTbx-siA1ZOg&r=BRpv_
> IJLfOPKPg5CMvWe7vPrIiVO97XiMOUrvOhs2KY&m=M35fKxVn4QneHylVYfwieO03S865S_
> inu-tl_w8GZ3A&s=g4tN6Qrv0ZvUhv-nq7KDKXHIH-OpCQcNIxVvHDG1Au0&e=
> .
> > com/2017/11/16/apache-atlas-update-have-you-been-watching/
> >
> > Open IGC is here!
> https://urldefense.proofpoint.com/v2/url?u=https-3A__
> dsrealtime.wordpress.com_2015_07_29_open-2Digc-2Dis-2D&d=
> DwIBaQ&c=jf_iaSHvJObTbx-siA1ZOg&r=BRpv_IJLfOPKPg5CMvWe7vPrIiVO97XiMOU
> rvOhs2KY&m=M35fKxVn4QneHylVYfwieO03S865S_inu-tl_w8GZ3A&s=
> FbLTJa1kLcMv0I3DkMzJP2aJpR0aTWpXb3SyAduO2gs&e=
>
> > here/
> >
> > [image: Inactive hide details for David Radley ---02/14/2018 07:44:19
> > AM---Hi Ernie, There are 2 ways to build and run Atlas currently:]David
> > Radley ---02/14/2018 07:44:19 AM---Hi Ernie, There are 2 ways to build
> and
> > run Atlas currently:
> >
> > From: David Radley <david_rad...@uk.ibm.com>
> > To: dev@atlas.apache.org
> > Date: 02/14/2018 07:44 AM
> > Subject: Re: Server appears to start, but connections fail with 503
> > ------------------------------
> >
> >
> >
> > Hi Ernie,
> > There are 2 ways to build and run Atlas currently:
> >        - external Hbase and Solr and ZK
> >        - embedded HBase Solr and ZK
> >
> > I am not sure which one you are trying. Sharing your build string would
> be
> > helpful. If you are using the embedded HBase option then you need to
> > specify environment variables, for the runtime Atlas to work,
> >
> > As per yesterdays call - Madhan suggests running with an external HBase,
> > as he seems a performance delay using the embedded HBase.
> >   all the best, David.
> >
> >
> >
> > From:   "Ernie Ostic" <eos...@us.ibm.com>
> > To:     "Atlas" <dev@atlas.apache.org>
> > Date:   14/02/2018 11:52
> > Subject:        Server appears to start, but connections fail with 503
> >
> >
> >
> >
> >
> > Hi all...
> >
> > Using "master", the build appears to be successful, and the server is
> > properly listening on port 21000, but quick start or even direct access
> > fails with 503.   Any suggestions on where to look?   Thanks!
> >
> > Ernie
> >
> >
> >
> > $ bin/quick_start.py
> >
> > log4j:WARN No such property [maxFileSize] in
> > org.apache.log4j.PatternLayout.
> > log4j:WARN No such property [maxBackupIndex] in
> > org.apache.log4j.PatternLayout.
> > log4j:WARN No such property [maxFileSize] in
> > org.apache.log4j.PatternLayout.
> > log4j:WARN No such property [maxBackupIndex] in
> > org.apache.log4j.PatternLayout.
> > log4j:WARN No such property [maxFileSize] in
> > org.apache.log4j.PatternLayout.
> >
> > Enter username for atlas :- admin
> > Enter password for atlas :-
> >
> > Creating sample types:
> >
> > Exception in thread "main" org.apache.atlas.AtlasServiceException:
> > Metadata
> > service API org.apache.atlas.AtlasClientV2$API_V2@1033576a failed with
> > status 503 (Service Unavailable) Response Body (<html>
> > <head>
> > <meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1"/>
> > <title>Error 503 </title>
> > </head>
> > <body>
> > <h2>HTTP ERROR: 503</h2>
> > <p>Problem accessing /api/atlas/v2/types/typedefs/. Reason:
> > <pre>    Service Unavailable</pre></p>
> > <hr /><a href="
> > https://urldefense.proofpoint.com/v2/url?u=http-3A__eclipse.
> > org_jetty&d=DwMFAg&c=jf_iaSHvJObTbx-siA1ZOg&r=
> > QhpUQPr5YlG95aAgCvZGStEXHg4hBbSYQ9JkRqR_svY&m=
> > 0y7mtLMoBMEc2RNTv8nhllpgWZHIGzqdnqcU0FUYtvg&s=
> > yRGEThijdpp0lFksddATlowggX7r9D_zX0z2DXZR8EA&e=
> > ">Powered by Jetty://
> > 9.3.14.v20161028</a><hr/>
> > </body>
> > </html>
> > )
> >                 at org.apache.atlas.AtlasBaseClient.callAPIWithResource
> > (AtlasBaseClient.java:388)
> >                 at org.apache.atlas.AtlasBaseClient.callAPIWithResource
> > (AtlasBaseClient.java:323)
> >                 at
> > org.apache.atlas.AtlasBaseClient.callAPI(AtlasBaseClient.java:211)
> >                 at org.apache.atlas.AtlasClientV2.createAtlasTypeDefs
> > (AtlasClientV2.java:227)
> >                 at org.apache.atlas.examples.QuickStartV2.createTypes
> > (QuickStartV2.java:185)
> >                 at org.apache.atlas.examples.QuickStartV2.runQuickstart
> > (QuickStartV2.java:141)
> >                 at
> > org.apache.atlas.examples.QuickStartV2.main(QuickStartV2.java:126)
> >
> > No sample data added to Apache Atlas Server.
> >
> >
> >
> > Ernie Ostic
> >
> > Worldwide Technical Sales
> > InfoSphere Information Server
> > IBM Analytics
> >
> > Cell: (617) 331 8238 <(617)%20331-8238>
> > ---------------------------------------------------------------
> > Apache Atlas Update!
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__
> > dsrealtime.wordpress.com_2017_11_16_apache-2Datlas-2Dupdate-
> >
> 2Dhave-2Dyou-2Dbeen-2Dwatching_&d=DwIBAg&c=jf_iaSHvJObTbx-siA1ZOg&r=BRpv_
> > IJLfOPKPg5CMvWe7vPrIiVO97XiMOUrvOhs2KY&m=M6GayZu1Kz1n1GaBTw60dDAEVnvATx
> > HnnOZGJSEzcpU&s=gs5vWioZh6a6c0_9DRS06onmI6SoY4Wxjtoi5INdgyc&e=
> >
> >
> > Open IGC is here!
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__
> > dsrealtime.wordpress.com_2015_07_29_open-2Digc-2Dis-2Dhere_&
> > d=DwIBAg&c=jf_iaSHvJObTbx-siA1ZOg&r=BRpv_IJLfOPKPg5CMvWe7vPrIiVO97XiMOU
> > rvOhs2KY&m=M6GayZu1Kz1n1GaBTw60dDAEVnvATxHnnOZGJSEzcpU&s=
> > zBAZF9LhSU96ytXo2OgCgXnZ8rriyL26nX82uskl8bY&e=
> >
> >
> >
> > Unless stated otherwise above:
> > IBM United Kingdom Limited - Registered in England and Wales with number
> > 741598.
> > Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6
> 3AU
> >
> >
> >
> >
>
>
>
>
> Unless stated otherwise above:
> IBM United Kingdom Limited - Registered in England and Wales with number
> 741598.
> Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU
>

Reply via email to