I did repeated runs of that particular test and it failed 6 of 100 runs.

───────────────────────────────────────────────────────────────────────────
for i in `seq 100` ; do
  mvn scalatest:test -pl sql-streaming-mqtt -q \
    -Dsuites='*.BasicMQTTSourceSuite @ Recovering offset from the last
processed offset.' | \
    grep -q "TEST FAILED" && echo "$i: failed"
done
───────────────────────────────────────────────────────────────────────────
1: failed
6: failed
22: failed
46: failed
77: failed
83: failed
───────────────────────────────────────────────────────────────────────────

The complete test suite BasicMQTTSourceSuite failed 56/100 times.

Similar behavior with Spark 2.0.1. so it should not be a regression.

I opened a JIRA to track/fix this:
https://issues.apache.org/jira/browse/BAHIR-83

Best regards,
Christian Kadner




From:   Ted Yu <yuzhih...@gmail.com>
To:     dev@bahir.apache.org
Date:   12/03/2016 01:41 PM
Subject:        Re: [VOTE] Apache Bahir 2.0.2 (RC1)



I got two test failures:

http://pastebin.com/P2J2jQzC

I use maven 3.3.9 and Java 8.

Does anyone else see the above ?

Cheers

On Sat, Dec 3, 2016 at 10:08 AM, Luciano Resende <luckbr1...@gmail.com>
wrote:

> Please vote to approve the release of the following candidate as Apache
> Bahir version 2.0.2 based on Apache Spark 2.0.2.
>
> The difference between 2.0.1 and 2.0.2 RC1 can be visualized at
>
> https://github.com/apache/bahir/compare/v2.0.1-rc1...v2.0.2-rc1
>
> The tag to be voted on is v2.0.2-rc1
> (1c411ea22e60e3f7b3e93fdbc6e2351cda816c90)
>
> https://github.com/apache/bahi
> r/tree/1c411ea22e60e3f7b3e93fdbc6e2351cda816c90
>
> The release files, including signatures, digests, etc. can be found at:
>
> https://repository.apache.org/content/repositories/orgapachebahir-1007
>
> The source distribution is also available at:
>
> https://dist.apache.org/repos/dist/dev/bahir/2.0.2-rc1/
>
> The vote is open for at least 72 hours and passes if a majority of at
least
> 3 +1 PMC votes are cast.
>
> [ ] +1 Release this package as Apache Bahir 2.0.1
> [ ] -1 Do not release this package because ...
>
> --
> Luciano Resende
> http://twitter.com/lresende1975
> http://lresende.blogspot.com/
>


Reply via email to