Gary Gregory wrote:

> On Wed, Oct 3, 2012 at 7:28 AM, Jörg Schaible <joerg.schai...@gmx.de>
> wrote:
> 
>> Jörg Schaible wrote:
>>
>> >
>> > sebb wrote:
>>
>> [snip]
>>
>> >> I find the naming convention rather difficult to follow.
>> >>
>> >> For example, the letter 's' sometimes means 'array' and sometimes
>> >> means 'string' Also M0 is not obvious as an abbreviation, nor is BeM0
>> >
>> > I am all open for better names, all *I* want to have is the
>> functionality.
>>
>> Has anyone a better idea for the names?
>>
> 
> I would probably loose the plural to indicate an array.

This is also ambiguous. Probably it would be better to use "array" directly. 
e.g.:

- byteArrayToLong
- longToByteArray


> I would expand M0 to Msb0 which itself is an acronym. Abbreviating an
> acronym is to mysterious to me.
> 
> So I'd end up with:
> 
> boolBeMsb0ToHexDigit(boolean[] src)
> 
> instead of:
> 
> boolsBeM0ToHexDigit(boolean[] src)

Sounds reasonable.

> I would use real examples in the Javadoc:
> 
>      * <p>
>      * (true, false, false, false) is converted as follow: '8' ...
> 
> instead of:
> 
>      * <p>
>      * (1, 0, 0, 0) is converted as follow: '8' ...
> 
> and use [ ] instead of ( ) to show an array

OK.

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org

Reply via email to