Should we rename RDFTermFactory to RDFFactory? Or just RDF? Someone
suggested that some time ago.

The reason is that it does quite more than creating RDFTerms, e.g.
creating triples, graphs and datasets.

This might make it more obvious why its instances would also include
'adaptation' methods from-to the underlying implementations, e.g.


RDF rdf = new JenaRDF();
IRI iri = rdf.createIRI("http://example.com/";);
Triple triple = rdf.createTriple(iri, iri, iri);
Graph g = rdf.createGraph();

We can keep a @Deprecated parent RDFTermFactory interface with the
0.2.0 method signatures (and remove it in 1.0.0)

Stian Soiland-Reyes

To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org

Reply via email to