The problem with the current API is that we can't get rid of the "Object"
suffix:

public static void different(long, long, String, Object...)
public static <T> void differentObject(T, T, String, Object...)

when I change the second method name to "different" (or rename both to
notEquals), the method calls become ambiguous. This has something to do
with the varargs argument at the end.

I'm currently not sure how to handle this. I'd rather like to release 3.5
without this API.

Thoughts?
Benedikt

Benedikt Ritter <brit...@apache.org> schrieb am So., 18. Sep. 2016 um
13:15 Uhr:

> Hello,
>
> sebb <seb...@gmail.com> schrieb am So., 18. Sep. 2016 um 12:21 Uhr:
>
>> I agree; use notEquals, greaterThan, lessThan
>>
>> 'different' is ambiguous - does it mean notSame or notEquals?
>>
>
> the latter.
>
>
>>
>> On 17 September 2016 at 16:57, Gary Gregory <garydgreg...@gmail.com>
>> wrote:
>> > JUnit makes the distinction between "same" for the same object and
>> "equals"
>> > and calling equals(), maybe this would help here.
>> >
>> > http://junit.org/junit4/javadoc/4.12/org/junit/Assert.html
>> >
>> > Gary
>> >
>> > On Sep 17, 2016 7:52 AM, "Benedikt Ritter" <brit...@apache.org> wrote:
>> >
>> >> Hi,
>> >>
>> >> LANG-1134 introduced new methods to Validate. I'm not fond of the API
>> as is
>> >> currently is. Here are my concerns:
>> >>
>> >> - When comparing numeral values usually we talk about greaterThan and
>> >> lessThan. The new API in Validate uses "smaller" and "greater"
>> >> - we have a method called "different" which checks that two reference
>> are
>> >> not equal to each other. Who about calling that notEquals?
>> >>
>> >> Regards,
>> >> Benedikt
>> >>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
>> For additional commands, e-mail: dev-h...@commons.apache.org
>>
>>

Reply via email to