On Fri, 9 Feb 2018 16:08:00 -0700, Bindul Bhowmik wrote:
On Fri, Feb 9, 2018 at 2:14 PM, Gilles <gil...@harfang.homelinux.org> wrote:
On Thu, 8 Feb 2018 22:44:32 -0700, Bindul Bhowmik wrote:

On Thu, Feb 8, 2018 at 9:01 AM, Gilles <gil...@harfang.homelinux.org>
wrote:

Hi.

Build succeeds with JDK 7 and 8 but not with JDK9:
  https://travis-ci.org/apache/commons-rng/jobs/337207823

Did someone encounter this problem?


Taking a guess here: looking at line 3521 of the log [1], it looks
like the symptom described in the surefire FAQ [2] about corrupted
streamps. I don't know RNG code to comment,


It's unikely to be caused by RNG; from the "dump", it looks
like error messages generated by "jacoco", that in turn
interfere with the "surefire" plugin's expectations.

but maybe a quick check
will be to try the build without forking (forkCount=0)


The build proceeds correctly with this setting.
Thanks.

Glad I could help. However, I might have a better solution for you. I
had a little time today, so checked out the code and tried the build;
and as you correctly noted above it is jacoco that is causing pain.
So, I tried updating the version of jacoco and the build works fine
with jacoco 0.8.0 (updated
<commons.jacoco.version>0.8.0</commons.jacoco.version>) and without
the forkCount configuration setting (basically default forkcount).
Looking at Jacoco's release notes [4], looks like you need 0.8.0 for
proper Java 9 support.

Thanks for the fix!


or using a
snapshot of surefire 2.21.0 [3], which seems to have a few more Java 9
goodies.


I don't know how to retrieve a snapshot version of the
plugin.

You can add the Apache snapshot repository [5] to your maven settings.
As of writing this email 2.21.0-SNAPSHOT from 08 FEB is available
there. You could also clone the surefire repository and build locally.

It is already the case; but I followed the link to the JIRA
project and used "2.21.0.Jigsaw" as the version rather than
"2.21.0-SNAPSHOT". That would explain why the dependency was
found...


But, either way, now you don't need to do it, updating JaCoCo should
fix your build issues.

Indeed.

Thanks again,
Gilles


Regards,
Bindul

[4] http://www.jacoco.org/jacoco/trunk/doc/changes.html
[5] https://repository.apache.org/content/repositories/snapshots/


Regards,
Gilles


Bindul

[1] https://travis-ci.org/apache/commons-rng/jobs/337207823#L3521
[2]



http://maven.apache.org/surefire/maven-surefire-plugin/faq.html#corruptedstream
[3] https://issues.apache.org/jira/projects/SUREFIRE/versions/12341630


Regards,
Gilles

P.S. Build also fails locally (on Debian "stretch") with the
     same error:
---CUT---
[...]
[ERROR] Error occurred in starting fork, check output in log
[ERROR] Process Exit Code: 134
[ERROR] org.apache.maven.surefire.booter.SurefireBooterForkException: The
forked VM terminated without properly saying goodbye. VM crash or
System.exit called?
[...]
---CUT---


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org

Reply via email to