Hi Xiaoyuan,
Seems this is the network access issue in China, You could have a try if
you could access http://www.twitter.com/.  Usually we need use VPN to get
access .


On Thu, Dec 1, 2016 at 9:10 PM, Xiaoyuan Chen <253441...@qq.com> wrote:

> Hi guys,
>   I downloaded the source code from here, the 0.3.51-RC1:
> http://distributedlog.incubator.apache.org/docs/latest/start/download
>   Like you said, I run the cmd:
>     mvn clean package -DskipTests
>   First problem: It got stuck in the process of trying to get the library
> : libthrift-0.5.0-1, always keeping retrying, like this:
>     Downloading: http://maven.twttr.com/org/apache/thrift/libthrift/0.5.0-
> 1/libthrift-0.5.0-1.pom
>   I don't know whether it's the problem of twitter or not. I'm sure there
> is no problem with my network. Fine, I installed this library manually,
> download from here:
>     http://mvnrepository.com/artifact/org.apache.thrift/libthrift/0.5.0-1
>   Ok, same problem again, It can't find the library : stats-util-0.0.58,
> installed manually too
>     Downloading: http://maven.twttr.com/com/twitter/common/stats-util/0.0.
> 58/stats-util-0.0.58.pom
>   BUT , second problem,
>     distributedlog-0.3.51-RC1/distributedlog-core/src/main/
> java/com/twitter/distributedlog/rate/SampledMovingAverageRate.java:[20,32]
>   it can't find the class Rate from com.twitter.common.stats, I check the
> library stats-util-0.0.58 , there is no class Rate in it indeed, AND I find
> it in the library stats-0.0.58.jar, weird, so I change the dependency to
> it, BUT it ended up in the same error, but it just can't resolve the method
> Rate.of(...).
>   That's it, how can I fix it? I need help. By the way, how can I import
> this project to the idea?
> Thanks

Reply via email to