> -----Original Message-----
> From: dev <dev-boun...@dpdk.org> On Behalf Of Joyce Kong
> Sent: Wednesday, June 24, 2020 4:45 PM
> To: jer...@marvell.com; maxime.coque...@redhat.com; Wang, Zhihong
> <zhihong.w...@intel.com>; Ye, Xiaolong <xiaolong...@intel.com>;
> ruifeng.w...@arm.com; honnappa.nagaraha...@arm.com; phil.y...@arm.com
> Cc: dev@dpdk.org; n...@arm.com
> Subject: [dpdk-dev] [PATCH v1] net/virtio: simplify variable name
> 
> Virtio_hw *hw has been pointed to vq->hw, it is better to use hw instead of 
> vq-
> >hw in later code.
> 
> Signed-off-by: Joyce Kong <joyce.k...@arm.com>
> ---
>  drivers/net/virtio/virtio_rxtx_simple_neon.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/virtio/virtio_rxtx_simple_neon.c
> b/drivers/net/virtio/virtio_rxtx_simple_neon.c
> index 363e2b330..8e6fa1fd7 100644
> --- a/drivers/net/virtio/virtio_rxtx_simple_neon.c
> +++ b/drivers/net/virtio/virtio_rxtx_simple_neon.c
> @@ -71,8 +71,8 @@ virtio_recv_pkts_vec(void *rx_queue, struct rte_mbuf
> **rx_pkts,
>        */
>       uint16x8_t len_adjust = {
>               0, 0,
> -             (uint16_t)vq->hw->vtnet_hdr_size, 0,
> -             (uint16_t)vq->hw->vtnet_hdr_size,
> +             (uint16_t)hw->vtnet_hdr_size, 0,
> +             (uint16_t)hw->vtnet_hdr_size,
>               0,
>               0, 0
>       };
> --
> 2.27.0

Reviewed-by: Chenbo Xia <chenbo....@intel.com>

Reply via email to