This patch set contains two patches, first of which is a prerequisite
for the second but can also be considered and applied independently.

The goal of this patch set is to solve the following problems:
* `bpf_def.h` fails to follow the DPDK naming rules for public headers
  in the name of the file or names of the symbols it defines;
* its symbols may clash with those in Linux headers but at the
  same time are not interchangable with them;
* small differences in opcode names relative to Linux are confusing.

v2:
* Following the AI suggestion renamed `RTE_EBPF_FUNC_MAX_ARGS` to
  `RTE_BPF_FUNC_MAX_ARGS`.
* Rebased on fresh main hoping to overcome the unrelated CI issues.
* Catiously re-posting without the RFC label.

Marat Khalili (2):
  bpf: make bpf_def.h private
  bpf: rename macros to match Linux kernel

 app/test/test_bpf.c              | 1685 +++++++++++++++---------------
 app/test/test_bpf_validate.c     |  268 ++---
 lib/bpf/bpf_convert.c            |   78 +-
 lib/bpf/bpf_def.h                |   91 +-
 lib/bpf/bpf_dump.c               |   45 +-
 lib/bpf/bpf_exec.c               |  156 +--
 lib/bpf/bpf_impl.h               |    5 +-
 lib/bpf/bpf_jit_arm64.c          |  218 ++--
 lib/bpf/bpf_jit_x86.c            |  312 +++---
 lib/bpf/bpf_load.c               |    2 +-
 lib/bpf/bpf_load_elf.c           |   24 +-
 lib/bpf/bpf_validate.c           |  310 +++---
 lib/bpf/bpf_validate.h           |    6 +-
 lib/bpf/bpf_validate_debug.c     |    6 +-
 lib/bpf/meson.build              |    1 -
 lib/bpf/rte_bpf.h                |   35 +-
 lib/bpf/rte_bpf_validate_debug.h |    8 +-
 17 files changed, 1623 insertions(+), 1627 deletions(-)

-- 
2.43.0

Reply via email to