Reformat the CP-DP synchronization sequence diagram in bpf_pkt.c by removing unnecessary vertical lines and re-centering arrow labels.
This comment-only commit is intentionally kept separate to make the diff of the preceding semantic change more readable. Signed-off-by: Marat Khalili <[email protected]> --- lib/bpf/bpf_pkt.c | 20 ++++++++------------ 1 file changed, 8 insertions(+), 12 deletions(-) diff --git a/lib/bpf/bpf_pkt.c b/lib/bpf/bpf_pkt.c index 429feb76ad..55f5947460 100644 --- a/lib/bpf/bpf_pkt.c +++ b/lib/bpf/bpf_pkt.c @@ -53,25 +53,21 @@ * | | | | | | * | |<---------------------- fetch callback -----------------------| * | | | | | | - * | | |<------------ store true ---------------------| + * | | |<---------------- store true -----------------| * | | | | | | * |-- remove callback -->| | | | rte_smp_mb() * | | | | | | * | | | |<------ fetch non-NULL --------| * | | | | | | - * |------------------- store NULL --------------------->| | | - * | | | | | | - * rte_smp_mb() | | | | | - * | | | | | | - * +-while use is true | | | | if cb not NULL-+ - * | | | | | | | | - * | +----------- fetch true ------------>| | |<-- execute --+ | - * | | | | | | BPF program | | - * | | | | | | +-+ + * |------------------- store NULL --------------------->| | if cb not NULL-+ + * | | | | | | | + * rte_smp_mb() | | | |<-- execute --+ | + * | | | | | BPF program | | + * +-while use is true | | | | +-+ * | | | | | | | - * | | | | | | rte_smp_rmb() + * | +---------- fetch true ------------->| | | rte_smp_rmb() * | | | | | | | - * +-+ | |<------------ store false --------------------| + * +-+ | |<---------------- store false ----------------| * | | | | | | * |------------ fetch false ------------>| | | | * | | | | | | -- 2.43.0

