Hi, have been using the Kafka integration quite often in the past and one thing I always have to explain when demonstrating code and which seems to confuse everyone seeing the code:
I would expect a KafkaConsumer to consume Edgent messages and publish them to Kafka and would expect a KafkaProducer to produce Edgent events. Unfortunately it seems to be the other way around. This seems a little unintuitive. Judging from the continued confusion when demonstrating code eventually it’s worth considering to rename these (swap their names). Eventually even rename them to “KafkaSource” (Edgent Source that consumes Kafka messages and produces Edgent events) and “KafkaConsumer” (Consumes Edgent Events and produces Kafka messages). After all the Classes are in the Edgent namespace and come from the Edgent libs, so the fixed point when inspecting these should be clear. Also I bet no one would be confused if we called something that produces Kafka messages a consumer as there should never be code that handles this from a Kafka point of view AND uses Edgent at the same time. Chris