Our coding convention is to preface all private vars with _ so you have _myVar as a private class scopes var and myVar as a method argument or temp var which only exists in the scope of the function. On Feb 12, 2013 6:27 PM, "Kevin Newman" <capta...@unfocus.com> wrote:
> This might seem like a minor thing, but I'd love to see a property > shortcut similar to coffee script, so instead of this.whateverProp, it'd be > @whateverProp. I know we can just omit "this." in AS3, but I think it's > actually harder to read that when you come back to a code base after a few > years (like I'm doing now). Using "this." or simply "@" to indicate a > property would more clearly distinguish between property and scope chain > variable, with a minimum of additional typing overhead. > > Kevin N. > >