Yes, very good points. I think we will be fixing these when we do the API cleanups that we discussed on the wiki design docs. In fact, the work I'm doing on https://issues.apache.org/jira/browse/FLINK-2398 can be seen as preparation for making these changes possible/easier.
On Tue, 28 Jul 2015 at 21:56 Matthias J. Sax <mj...@informatik.hu-berlin.de> wrote: > Hi, > > I am a little bit confused about the class hierarchy of DataStream. It > has three subclasses: KeyedDataStream, SingleOutputStreamOperator, and > SplitDataStream. > > 1) Why is the name "SingleOutputStreamOperator" (why OPERATOR ??) > > 2) Is it correct, that a SplitDataStream emit multiple logical output > streams, while SingleOutputStreamOperator and KeyedDataStream emit a > single logical output stream? > => If yes, why is a KeyedDataStream not a subclass of > SingleOutputStreamOperator ? > > 3) > a) Why does only SingleOutputStreamOperator has method name()/getName()? > b) Why does only SingleOutputStreamOperator has method setParallelism()? > c) Should those methods be members of DataStream instead? > > > > -Matthias > >