----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57573/ -----------------------------------------------------------
(Updated March 15, 2017, 8:02 p.m.) Review request for geode, Jinmei Liao, Jared Stewart, Kevin Duling, Ken Howe, and Patrick Rhomberg. Changes ------- Change numberOfFiles to ignore dirOfDeletedFiles by removing it from the list of files returned from dir.listFile(). Add ArrayUtils.asList as modifiable version of Arrays.asList. Rename ArrayUtilsJUnitTest to ArrayUtilsTest. Convert ArrayUtilsTest to use AssertJ and to better follow unit test best practices. Bugs: GEODE-2648 https://issues.apache.org/jira/browse/GEODE-2648 Repository: geode Description (updated) ------- GEODE-2648: always move deleted files to dirOfDeletedFiles Fix flaky test by always moving deleted files to dirOfDeletedFiles to avoid race condition in which file is deleted before its presence can be detected. Update: ```java // Arrays.asList returns unmodifiable list List<String> unmodifiable = Arrays.asList("Larry", "Moe", "Curly"); unmodifiable.remove("Curly"); <-- throws UnsupportedOperationException ``` I created a new modifiable version of asList and added it to the Geode ArrayUtils class and used this new utility in DiskSpaceLimitIntegrationTest as part of the recommendation in Ken's review. Diffs (updated) ----- geode-core/src/main/java/org/apache/geode/internal/util/ArrayUtils.java 3459e16c8f9b4c7d0ebb070bba2e0b2e55a69381 geode-core/src/test/java/org/apache/geode/internal/statistics/DiskSpaceLimitIntegrationTest.java 5d94fa0ba32aabc0f0bfc396d99d0b5ef9572360 geode-core/src/test/java/org/apache/geode/internal/util/ArrayUtilsJUnitTest.java 3ec8b12b5ad7bc86556d1259be0b3e2e9a240845 geode-core/src/test/java/org/apache/geode/internal/util/ArrayUtilsTest.java PRE-CREATION Diff: https://reviews.apache.org/r/57573/diff/2/ Changes: https://reviews.apache.org/r/57573/diff/1-2/ Testing ------- DiskSpaceLimitIntegrationTest precheckin in progress Thanks, Kirk Lund