I think now is the time to discuss if we want to commit the change from configId to moduleId. If we decide to commit the patch, the timing of the actual commit will be determined by Kevan to have the smallest impact on the TCK. The patch makes the following changes:

  o Renamed root element from "configuration" to "module"
  o Renamed environment element from "configId" to "moduleId"
o Renamed schema from "geronimo-config-1.1.xsd" to "geronimo- module-1.1.xsd"

Based on conversations over the past few days, I think we all agree that "configuration" is a poor name choice, and we want to change it. I also think that we all agree that if we are going to make the change we should change the xml schemas before 1.1 ships to have minimal impact on users (we already have schema changes going into 1.1).

Should we commit?

-dain

Reply via email to