Michael Osipov commented on HTTPCLIENT-2031:

I agree with the enumeration, but that is still pointless because you cannot 
retreive an auth scheme impl for an auth scheme. You have to query the registry 
which contains -- surprise -- string keys...

I would not add {{CUSTOM}} because this is

a) counter-intuitive compared to the already present values
b) you won't be able to register two or more custom auth schemes based on their 

Unless someone has a briliant idea how to solve this decently, I can only 
rename {{ChainElements}} because everything else feels like a tradeoff w/o a 
significant improvement.

> Don't use plural names for enums
> --------------------------------
>                 Key: HTTPCLIENT-2031
>                 URL: https://issues.apache.org/jira/browse/HTTPCLIENT-2031
>             Project: HttpComponents HttpClient
>          Issue Type: Bug
>          Components: HttpClient (async), HttpClient (classic)
>    Affects Versions: 5.0 Beta6
>            Reporter: Michael Osipov
>            Assignee: Michael Osipov
>            Priority: Major
> In Java world, the general concensus to have enum names to be singular, yes 
> some of are in plural:
> {noformat}
> org.apache.hc.client5.http.async.methods.HttpRequests
> org.apache.hc.client5.http.async.methods.SimpleHttpRequests
> org.apache.hc.client5.http.auth.AuthSchemes
> org.apache.hc.client5.http.classic.methods.ClassicHttpRequests
> org.apache.hc.client5.http.cookie.CookieSpecs
> org.apache.hc.client5.http.impl.ChainElements
> {noformat}
> See also https://docs.oracle.com/javase/tutorial/java/javaOO/enum.html and 
> https://stackoverflow.com/a/15756009/696632
> If no one objects ([~olegk],  [~ggregory]), I will alter this on master.

This message was sent by Atlassian Jira

To unsubscribe, e-mail: dev-unsubscr...@hc.apache.org
For additional commands, e-mail: dev-h...@hc.apache.org

Reply via email to