[ https://issues.apache.org/jira/browse/HIVE-1990?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12994941#comment-12994941 ]
Joep Rottinghuis commented on HIVE-1990: ---------------------------------------- Good point Ashutosh. This change does not seem to break unit tests, but would indeed break when running with Hadoop 0.17, 0.18, 0.29, or plain 0.20. I see three options: 1) Leave this as a standalone for who wants to run against 0.20.100. In those cases it is unlikely that they'll ever run against the other shimmed in versions anyway. Your cluster is more likely to be either one of the other. 2) File a bug against Hadoop 0.20.100 to see if there is apetite to move Metrics back to o.a.h.metrics.jvm 3) Build in more sophistication into the build to be able to pick one config file or the other, depending on the version of Hadoop. (options are in increasing level of effort). > Logging fails due to moved EventCounter class in Hadoop 0.20.100 > ---------------------------------------------------------------- > > Key: HIVE-1990 > URL: https://issues.apache.org/jira/browse/HIVE-1990 > Project: Hive > Issue Type: Bug > Components: Logging > Affects Versions: 0.6.0 > Environment: Red Hat 2.6.18 > Reporter: Joep Rottinghuis > Fix For: 0.6.0 > > Attachments: hive-1990.patch > > > When compiling Hive against Hadoop 0.20.100 logging on command line and in > unit tests fails due to the EventCounter class being moved from > o.a.h.metrics.jvm.EventCounter to o.a.h.log.EventCounter. > {code} > [junit] Running org.apache.hadoop.hive.serde2.TestTCTLSeparatedProtocol > [junit] log4j:ERROR Could not instantiate class > [org.apache.hadoop.metrics.jvm.EventCounter]. > [junit] java.lang.ClassNotFoundException: > org.apache.hadoop.metrics.jvm.EventCounter > [junit] at java.net.URLClassLoader$1.run(URLClassLoader.java:200) > [junit] at java.security.AccessController.doPrivileged(Native Method) > [junit] at java.net.URLClassLoader.findClass(URLClassLoader.java:188) > [junit] at java.lang.ClassLoader.loadClass(ClassLoader.java:307) > [junit] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) > [junit] at java.lang.ClassLoader.loadClass(ClassLoader.java:252) > {code} > As a note: In order to re-produce I first applied patch as per HIVE-1264 to > 0.6 branch in order to resolve jar naming issues in build. > Then I locally modified the build.properties to my locally built 0.20.100 > Hadoop build: > {code} > hadoop.security.url=file:////<...>/hadoop/core/hadoop-${hadoop.version} > hadoop.security.version=${hadoop.version} > {code} -- This message is automatically generated by JIRA. - For more information on JIRA, see: http://www.atlassian.com/software/jira