[ https://issues.apache.org/jira/browse/HIVE-1990?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12995094#comment-12995094 ]
Ashutosh Chauhan commented on HIVE-1990: ---------------------------------------- This is kind of tricky. It has been stated that Hive trunk currently supports only 20 and 20-secure (someone can correct me here if its not correct). Since there was no official apache release for hadoop-0.20 yet, Hive relied on 0.20.3-CDH3-SNAPSHOT for security integration which didn't have this issue. But, now with official Apache release knocking on door (0.20.100) we should probably switch over to that and then we need to commit this fix. > Logging fails due to moved EventCounter class in Hadoop 0.20.100 > ---------------------------------------------------------------- > > Key: HIVE-1990 > URL: https://issues.apache.org/jira/browse/HIVE-1990 > Project: Hive > Issue Type: Bug > Components: Logging > Affects Versions: 0.6.0 > Environment: Red Hat 2.6.18 > Reporter: Joep Rottinghuis > Fix For: 0.6.0 > > Attachments: hive-1990.patch > > > When compiling Hive against Hadoop 0.20.100 logging on command line and in > unit tests fails due to the EventCounter class being moved from > o.a.h.metrics.jvm.EventCounter to o.a.h.log.EventCounter. > {code} > [junit] Running org.apache.hadoop.hive.serde2.TestTCTLSeparatedProtocol > [junit] log4j:ERROR Could not instantiate class > [org.apache.hadoop.metrics.jvm.EventCounter]. > [junit] java.lang.ClassNotFoundException: > org.apache.hadoop.metrics.jvm.EventCounter > [junit] at java.net.URLClassLoader$1.run(URLClassLoader.java:200) > [junit] at java.security.AccessController.doPrivileged(Native Method) > [junit] at java.net.URLClassLoader.findClass(URLClassLoader.java:188) > [junit] at java.lang.ClassLoader.loadClass(ClassLoader.java:307) > [junit] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) > [junit] at java.lang.ClassLoader.loadClass(ClassLoader.java:252) > {code} > As a note: In order to re-produce I first applied patch as per HIVE-1264 to > 0.6 branch in order to resolve jar naming issues in build. > Then I locally modified the build.properties to my locally built 0.20.100 > Hadoop build: > {code} > hadoop.security.url=file:////<...>/hadoop/core/hadoop-${hadoop.version} > hadoop.security.version=${hadoop.version} > {code} -- This message is automatically generated by JIRA. - For more information on JIRA, see: http://www.atlassian.com/software/jira