-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/60950/#review180897
-----------------------------------------------------------




metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
Lines 283 (patched)
<https://reviews.apache.org/r/60950/#comment256218>

    is this really needed ? see comment below.



metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
Lines 393 (patched)
<https://reviews.apache.org/r/60950/#comment256214>

    If you make this static, I think you can do away with the need of creating 
a thread local HMSHandler (threadLocalHMSHandler), i.e. You already have a 
thread local map (threadLocalModifiedMetaConfKeys), so you should not need to 
reference it using another thread local (threadLocalHMSHandler).



metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
Lines 396 (patched)
<https://reviews.apache.org/r/60950/#comment256215>

    Please rename m to something more clear (in this context), like 
modifiedConfig.



metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
Lines 403 (patched)
<https://reviews.apache.org/r/60950/#comment256216>

    nit: just use threadLocalConf.get() directly, get rid of the conf above



metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
Lines 412 (patched)
<https://reviews.apache.org/r/60950/#comment256217>

    For clarity, move this to finally() inside cleanupRawStore(), so that all 
thread local cleanup is captured in one place as 
HMSHandler.threadLocalModifiedMetaConfKeys.remove().


- Mohit Sabharwal


On July 18, 2017, 10:58 p.m., PRASHANT GOLASH wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/60950/
> -----------------------------------------------------------
> 
> (Updated July 18, 2017, 10:58 p.m.)
> 
> 
> Review request for hive.
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> Added the code to notify meta listeners during shutdown. Shutdown would 
> eventually call cleanupRawStore (In both cases HMSHandler#close and 
> TServerEventHandler#DeleteContext), so called the notification code in that 
> function.
> 
> 
> Diffs
> -----
> 
>   
> itests/hive-unit/src/test/java/org/apache/hadoop/hive/metastore/TestMetaStoreEventListener.java
>  fd4527e653 
>   metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java 
> 58b9044930 
> 
> 
> Diff: https://reviews.apache.org/r/60950/diff/2/
> 
> 
> Testing
> -------
> 
> Added unit test cases for the affected codepath.
> 
> 
> Thanks,
> 
> PRASHANT GOLASH
> 
>

Reply via email to