-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65985/#review199063
-----------------------------------------------------------




standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/HiveAlterHandler.java
Lines 362 (patched)
<https://reviews.apache.org/r/65985/#comment279355>

    Would it make sense to move this out to its own try/catch block? This would 
avoid confusion with transaction try/catch block.



standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/HiveAlterHandler.java
Lines 365 (patched)
<https://reviews.apache.org/r/65985/#comment279358>

    This may cause weird situation where operation succeeds and is commitetd 
but throws an exception.



standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/HiveAlterHandler.java
Lines 366 (patched)
<https://reviews.apache.org/r/65985/#comment279356>

    It may be easier to read if you use 
    
        if (listeners.isEmpty()) {
          return;
        }



standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/HiveAlterHandler.java
Lines 372 (patched)
<https://reviews.apache.org/r/65985/#comment279357>

    Why are we creating dropTable/createTable notifications here? I understand 
that this mimics the code above, but it looks suspicious.



standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/IHMSHandler.java
Lines 99 (patched)
<https://reviews.apache.org/r/65985/#comment279354>

    There is only a single consumer of this interface - it seems odd to have an 
interface which is used in some special case. Should all access to listeners be 
converted to the interface?


- Alexander Kolbasov


On March 8, 2018, 4:11 p.m., Sergio Pena wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/65985/
> -----------------------------------------------------------
> 
> (Updated March 8, 2018, 4:11 p.m.)
> 
> 
> Review request for hive, Alexander Kolbasov, Sahil Takiar, and Vihang 
> Karajgaonkar.
> 
> 
> Bugs: HIVE-18783
>     https://issues.apache.org/jira/browse/HIVE-18783
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> HIVE-16164 introduced a mechanism to pass HMS notification events ID to the 
> post-commit listeners for all DDL operations, but it didn't add it to the 
> ALTER TABLE event. This patch in review adds the same behavior for ALTER 
> TABLE events.
> 
> 
> Diffs
> -----
> 
>   
> itests/hcatalog-unit/src/test/java/org/apache/hive/hcatalog/listener/TestDbNotificationListener.java
>  e0e29652da94bbdaca515a17955d1409824c1742 
>   
> standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/HiveAlterHandler.java
>  89354a2d34249903a9ff13c4ed913a68de93057e 
>   
> standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
>  662de9a66767f27f31998f14c68f854e59993ab6 
>   
> standalone-metastore/src/main/java/org/apache/hadoop/hive/metastore/IHMSHandler.java
>  e6de00100003bc1be12b2772e2e97102ed476cf5 
> 
> 
> Diff: https://reviews.apache.org/r/65985/diff/1/
> 
> 
> Testing
> -------
> 
> All tests passed.
> 
> 
> Thanks,
> 
> Sergio Pena
> 
>

Reply via email to