[
https://issues.apache.org/jira/browse/JCRVLT-120?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15398736#comment-15398736
]
Tobias Bocanegra commented on JCRVLT-120:
-----------------------------------------
I think this should work. although I think the logic is a bit more complicated.
eg, to be backward compatible, the original includes/exclude need to match all
properties. so they implicitly define a property filter that matches all.
{noformat}
<filter root="/content">
<include pattern="/content/.*" />
<exclude pattern=".*/cq:lastReplicated" matchProperties="true" />
<include pattern="/content/foo" />
</filter>
{noformat}
the intention should be, that the last pattern includes all properties again
below /contemt/foo. so maybe the default for property filter should always be a
include.
btw: I would rename the {{getFilterSets(boolean applyToNodes)}}. it looks
awkward. rather: {{getPropertyFilterSets()}}
> Allow to filter content properties based on property name and value
> --------------------------------------------------------------------
>
> Key: JCRVLT-120
> URL: https://issues.apache.org/jira/browse/JCRVLT-120
> Project: Jackrabbit FileVault
> Issue Type: Improvement
> Components: vlt
> Affects Versions: 3.1.26
> Reporter: Timothee Maret
> Attachments: JCRVLT-120.patch
>
>
> In our use case, we need to filter content distributed by filevault for
> properties {{cq:lastReplicated}}, {{cq:lastReplicatedBy}} and
> {{cq:lastReplicationAction}}.
> This feature could cover more than those three property and instead be
> generalised to filter any property which name and value match the configured
> filter.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)