-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35820/#review90605
-----------------------------------------------------------


Thanks for the patch. A few more comments below.


core/src/main/scala/kafka/controller/KafkaController.scala (line 42)
<https://reviews.apache.org/r/35820/#comment143710>

    Implicits can have unexpected side effects. Could we limit the scope of 
this by importing it in the context where conversion is actually used?



core/src/main/scala/kafka/utils/ReplicationUtils.scala (line 44)
<https://reviews.apache.org/r/35820/#comment143712>

    It's better to make this debug level.



core/src/test/scala/unit/kafka/integration/TopicMetadataTest.scala (line 45)
<https://reviews.apache.org/r/35820/#comment143732>

    This seems to be specific to testIsrAfterBrokerShutDownAndJoinsBack. Could 
we move it there?



core/src/test/scala/unit/kafka/integration/TopicMetadataTest.scala (line 138)
<https://reviews.apache.org/r/35820/#comment143713>

    Can this be private?



core/src/test/scala/unit/kafka/integration/TopicMetadataTest.scala (line 147)
<https://reviews.apache.org/r/35820/#comment143723>

    We should use foreach instead of map.



core/src/test/scala/unit/kafka/integration/TopicMetadataTest.scala (lines 149 - 
163)
<https://reviews.apache.org/r/35820/#comment143731>

    Could we align the code a bit to make it more readable?



core/src/test/scala/unit/kafka/integration/TopicMetadataTest.scala (lines 152 - 
154)
<https://reviews.apache.org/r/35820/#comment143730>

    It seems that we have to deal with the case of hostName being empty here 
too. It's probably simpler to just create BrokerEndPoint in the same way as in 
line 141.


- Jun Rao


On July 2, 2015, 12:23 a.m., Ashish Singh wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/35820/
> -----------------------------------------------------------
> 
> (Updated July 2, 2015, 12:23 a.m.)
> 
> 
> Review request for kafka.
> 
> 
> Bugs: KAFKA-1367
>     https://issues.apache.org/jira/browse/KAFKA-1367
> 
> 
> Repository: kafka
> 
> 
> Description
> -------
> 
> KAFKA-1367: Broker topic metadata not kept in sync with ZooKeeper
> 
> 
> Diffs
> -----
> 
>   core/src/main/scala/kafka/common/TopicAndPartition.scala 
> df3db912f5daef6a25b4b2dd2220d2cc3795bce6 
>   core/src/main/scala/kafka/controller/KafkaController.scala 
> 36350579b16027359d237b64699003358704ac6f 
>   core/src/main/scala/kafka/utils/ReplicationUtils.scala 
> 60687332b4c9bee4d4c0851314cfb4b02d5d3489 
>   core/src/main/scala/kafka/utils/ZkUtils.scala 
> 78475e3d5ec477cef00caeaa34ff2d196466be96 
>   core/src/test/scala/unit/kafka/integration/TopicMetadataTest.scala 
> 995b05901491bb0dbf0df210d44bd1d7f66fdc82 
>   core/src/test/scala/unit/kafka/utils/ReplicationUtilsTest.scala 
> c96c0ffd958d63c09880d436b2e5ae96f51ead36 
> 
> Diff: https://reviews.apache.org/r/35820/diff/
> 
> 
> Testing
> -------
> 
> Tested on a test cluster with 3 Kafka brokers
> 
> 
> Thanks,
> 
> Ashish Singh
> 
>

Reply via email to