I think that something is not well defined under your inventory as this
error arrives due to the following reason

def lib_utils_oo_image_tag_to_rpm_version(version, include_dash=False):
    """ Convert an image tag string to an RPM version if necessary
        Empty strings and strings that are already in rpm version format
        are ignored. Also remove non semantic version components.

        Ex. v3.2.0.10 -> -3.2.0.10
            v1.2.0-rc1 -> -1.2.0
    """
    if not isinstance(version, string_types):
        raise errors.AnsibleFilterError("|failed expects a string or
unicode")


CHARLES MOULLIARD

SOFTWARE ENGINEER MANAGER SPRING(BOOT)

Red Hat <https://www.redhat.com/>

cmoulli...@redhat.com    M: +32-473-604014
<https://red.ht/sig>
@cmoulliard <https://twitter.com/cmoulliard>

On Tue, Apr 10, 2018 at 2:17 PM, Clayton Coleman <ccole...@redhat.com>
wrote:

> You can try rerunning the install with -vv to get additional debug
> information.
>
> What OS and version on Ansible are you using?
>
> On Apr 10, 2018, at 3:24 AM, Yu Wei <yu20...@hotmail.com> wrote:
>
> Hi,
> I tried to install openshift origin 3.9 on a single machine and
> encountered problems as below,
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> *TASK [openshift_node : Install Node package, sdn-ovs, conntrack packages]
> *********************************************************************
> fatal: [host-10-1-241-74]: FAILED! => {"msg": "|failed expects a string or
> unicode"}     to retry, use: --limit
> @/root/jared/openshift-ansible/playbooks/deploy_cluster.retry PLAY RECAP
> ************************************************************************************************************************************
> host-10-1-241-74           : ok=326  changed=41   unreachable=0
> failed=1    localhost                  : ok=13   changed=0
> unreachable=0    failed=0    INSTALLER STATUS
> ******************************************************************************************************************************
> Initialization             : Complete (0:00:43) Health Check
> : Complete (0:00:05) etcd Install               : Complete (0:00:58) Master
> Install             : Complete (0:05:03) Master Additional Install  :
> Complete (0:00:48) Node Install               : In Progress (0:00:38)
>  This phase can be restarted by running:
> playbooks/openshift-node/config.yml Failure summary:   1. Hosts:
> host-10-1-241-74      Play:     Configure containerized nodes
> Task:     Install Node package, sdn-ovs, conntrack packages      Message:
> |failed expects a string or unicode*
>
> I didn't find useful information in docker / journal logs.
> How could I fix this problem further?
>
> Thanks,
>
> Jared, (韦煜)
> Software developer
> Interested in open source software, big data, Linux
>
> _______________________________________________
> dev mailing list
> dev@lists.openshift.redhat.com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
>
>
> _______________________________________________
> users mailing list
> us...@lists.openshift.redhat.com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/users
>
>
_______________________________________________
dev mailing list
dev@lists.openshift.redhat.com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev

Reply via email to