In my previous installation, "openshift_release" and "openshift_pkg_version" 
were set to 3.9 and installation failed.
I changed the value to v3.9, it worked now.
When I installed OpenShift Origin 3.6, the value was set to 3.6 without prefix 

Is there any changes?

Thanks again for help.
From: Charles Moulliard <>
Sent: Tuesday, April 10, 2018 8:24 PM
To: Clayton Coleman
Cc: Yu Wei;;
Subject: Re: Install OpenShift Origin 3.9 failed on single node

I think that something is not well defined under your inventory as this error 
arrives due to the following reason

def lib_utils_oo_image_tag_to_rpm_version(version, include_dash=False):
    """ Convert an image tag string to an RPM version if necessary
        Empty strings and strings that are already in rpm version format
        are ignored. Also remove non semantic version components.

        Ex. v3.2.0.10 -> -
            v1.2.0-rc1 -> -1.2.0
    if not isinstance(version, string_types):
        raise errors.AnsibleFilterError("|failed expects a string or unicode")



Red Hat<><>    M: 


On Tue, Apr 10, 2018 at 2:17 PM, Clayton Coleman 
<<>> wrote:
You can try rerunning the install with -vv to get additional debug information.

What OS and version on Ansible are you using?

On Apr 10, 2018, at 3:24 AM, Yu Wei 
<<>> wrote:

I tried to install openshift origin 3.9 on a single machine and encountered 
problems as below,

TASK [openshift_node : Install Node package, sdn-ovs, conntrack packages] 
fatal: [host-10-1-241-74]: FAILED! => {"msg": "|failed expects a string or 
    to retry, use: --limit 

host-10-1-241-74           : ok=326  changed=41   unreachable=0    failed=1
localhost                  : ok=13   changed=0    unreachable=0    failed=0

Initialization             : Complete (0:00:43)
Health Check               : Complete (0:00:05)
etcd Install               : Complete (0:00:58)
Master Install             : Complete (0:05:03)
Master Additional Install  : Complete (0:00:48)
Node Install               : In Progress (0:00:38)
    This phase can be restarted by running: playbooks/openshift-node/config.yml

Failure summary:

  1. Hosts:    host-10-1-241-74
     Play:     Configure containerized nodes
     Task:     Install Node package, sdn-ovs, conntrack packages
     Message:  |failed expects a string or unicode

I didn't find useful information in docker / journal logs.
How could I fix this problem further?


Jared, (韦煜)
Software developer
Interested in open source software, big data, Linux

dev mailing list<>

users mailing list<>

dev mailing list

Reply via email to