Hello,

`dlarnv` comes from LAPACK [1] what implementation do you use (ATLAS, 
refLAPACK, MKL, OpenBlas) ?

Could you also attach the config.log please ?

[1]: http://www.netlib.org/lapack/explore-html/db/d9c/dlarnv_8f.html

Thanks,

--
Clément

Le jeudi 22 septembre 2016 à 17:01 +0900, Masaru Nomiya a écrit :
> Hello,
> 
> I got the very latest git head of scilab, and tried to compile.
> But, ./configure failes;
> 
> [...]
> Generic Blas found
> checking if LAPACK is available... 
> checking for cheev_... no
> checking for cheev_ in -llapack... yes
> Library -llapack found
> checking if ARPACK-NG is available... 
> checking for znaupd_ in -larpack... yes
> ARPACK-NG library found
> checking whether the arpack library works... 
> configure: error: ARPACK library found, but seems not to work properly. 
> Please make sure you are
> using arpack-ng
> 
> About this config.log tells me;
> 
> [...]
> ./conftest: symbol lookup error: /usr/lib64/libarpack.so.2: undefined symbol: 
> dlarnv_
> [...]
> 
> Isn't this a bug?
> 
> I tried with;
> 
> 1. arpack-ng 3.1.2
> 2. arpack-ng 3.3.0
> 3. arpack-ng 3.4.0
> 
> I got same results with these.
> 
> Any hint?
> 
> ---
> ┏━━┓彡 Masaru Nomiya             mail-to: nomiya @ galaxy.dti.ne.jp
> ┃\/彡
> ┗━━┛ "Bill! You married with Computers.
>           Not with Me!"
>          "No..., with money."
> _______________________________________________
> dev mailing list
> dev@lists.scilab.org
> http://lists.scilab.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@lists.scilab.org
http://lists.scilab.org/mailman/listinfo/dev

Reply via email to