yes, thanks!

On Fri, Apr 13, 2018 at 7:05 PM, Michael McCandless (JIRA) <j...@apache.org>
wrote:

>
>     [ https://issues.apache.org/jira/browse/LUCENE-8248?page=
> com.atlassian.jira.plugin.system.issuetabpanels:comment-
> tabpanel&focusedCommentId=16438060#comment-16438060 ]
>
> Michael McCandless commented on LUCENE-8248:
> --------------------------------------------
>
> Woops, thanks [~varunthacker]!
>
> > Rename MergePolicyWrapper to FilterMergePolicy and override all of
> MergePolicy
> > ------------------------------------------------------------
> ------------------
> >
> >                 Key: LUCENE-8248
> >                 URL: https://issues.apache.org/jira/browse/LUCENE-8248
> >             Project: Lucene - Core
> >          Issue Type: Wish
> >          Components: core/index
> >            Reporter: Mike Sokolov
> >            Priority: Minor
> >             Fix For: 7.4, master (8.0)
> >
> >         Attachments: LUCENE-8248.1.patch, LUCENE-8248.2.patch,
> LUCENE-8248.patch, LUCENE-8248.patch, MergePolicy.patch
> >
> >
> > MergePolicy.getMaxCFSSegmentSizeMB is final, but the corresponding
> setter is not, which means that overriding it with anything other than a
> trivial delegation can only lead to confusion.
> > The patch makes the method final and removes the trivial implementations
> from MergePolicyWrapper and NoMergePolicy.
> > [~mikemccand] also pointed out that the class name is nonstandard for
> similar adapter classes in Lucene, which are usually Filter*.java.
> Personally I was looking for MergePolicyAdapter, but if there is a
> prevailing convention here around Filter, does it make sense to change this
> class's name to FilterMergePolicy?
>
>
>
> --
> This message was sent by Atlassian JIRA
> (v7.6.3#76005)
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
> For additional commands, e-mail: dev-h...@lucene.apache.org
>
>

Reply via email to