[ 
https://issues.apache.org/jira/browse/LUCENE-8449?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16578672#comment-16578672
 ] 

ASF subversion and git services commented on LUCENE-8449:
---------------------------------------------------------

Commit bb5816357810094abf05d34a2b9325182f36fcd1 in lucene-solr's branch 
refs/heads/master from danmuzi
[ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=bb58163 ]

LUCENE-8449: Code Optimizations in FieldTermStack

Signed-off-by: Adrien Grand <jpou...@gmail.com>


> Code Optimizations in FieldTermStack
> ------------------------------------
>
>                 Key: LUCENE-8449
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8449
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: modules/highlighter
>            Reporter: Namgyu Kim
>            Priority: Minor
>              Labels: newbie, performance
>         Attachments: 
> 0001-LUCENE-8449-Code-Optimizations-in-FieldTermStack.patch
>
>
> -1) "vector.hasPositions() == false" in FieldTermStack's constructor-
> -can be changed to "*!vector.hasPositions()*"-
>  
> 2) "public TermInfo(String, int, int, int, float)" constructor
> can be change to "*TermInfo(String, int, int, int, float)*"
>  
> 3) TermInfo's toString method
> {code:java}
> public String toString() {
>       StringBuilder sb = new StringBuilder();
>       sb.append( text ).append( '(' ).append(startOffset).append      ( ',' 
> ).append( endOffset ).append( ',' ).append( position ).append( ')' );
>       return sb.toString();
> }{code}
> This code can be changed to
>  
> {code:java}
> public String toString(){
>   return text + '(' + startOffset + ',' + endOffset + ',' + position + ')';
> }
> {code}
> this code.
>  
>  
> 4) TermInfo's equals method
> {code:java}
> public boolean equals(Object obj) {
>       ...
>       if (position != other.position) {
>               return false;
>       }
>       return true;
> }
> {code}
> This code can be changed to
>  
> {code:java}
> public boolean equals(Object obj) {
>       ...
>       return position == other.position;
> }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to