Let's just go for Java 7... this is linked to core... if you are stuck on
an older Java likely you can't upgrade Maven anyway

On Sunday 16 October 2016, Christian Schulte <c...@schulte.it> wrote:

> Am 10/16/16 um 22:51 schrieb Michael Osipov:
> > Am 2016-10-16 um 22:48 schrieb Christian Schulte:
> >> Will the resolver be upgraded to Java 7? I would use 'java.util.Objects'
> >> then.
> >
> > I have the very same idea. I wouldn't mind using j.u.Objects instead of
> > o.a.c.l4.Validate.
> >
> > Is there any compelling reason not to switch to Java 7? NIO2 and
> > try-with-resources is nice.
> >
>
> +1 for Java 7
>
> Maven already is targeting Java 7. Depends on the other users of the
> resolver. If one of them still is not at Java 7, we will not be able to
> upgrade. I would not upgrade to Java 6 and keep it Java 5 then. So we go
> from 5 to 7 somewhen and skip 6.
>
> Regards,
> --
> Christian
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscr...@maven.apache.org <javascript:;>
> For additional commands, e-mail: dev-h...@maven.apache.org <javascript:;>
>
>

-- 
Sent from my phone

Reply via email to