----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/22539/#review47018 -----------------------------------------------------------
looks good. some minor fixes before we can commit this. src/Makefile.am <https://reviews.apache.org/r/22539/#comment82614> All our example frameworks use libprocess. Did you add the "libprocess" suffix because you are planning to write other example frameworks that don't use libprocess? if not, kill that suffix. src/examples/low_level_scheduler_libprocess.cpp <https://reviews.apache.org/r/22539/#comment82616> s/to/with/ src/examples/low_level_scheduler_libprocess.cpp <https://reviews.apache.org/r/22539/#comment82617> How about: TODO(zuyu): Do batch processing of UPDATE events. src/examples/low_level_scheduler_libprocess.cpp <https://reviews.apache.org/r/22539/#comment82618> s/failed/terminated/ src/examples/low_level_scheduler_libprocess.cpp <https://reviews.apache.org/r/22539/#comment82619> s/failed/terminated/ src/examples/low_level_scheduler_libprocess.cpp <https://reviews.apache.org/r/22539/#comment82620> This should be CHECK because this is not possible. src/examples/low_level_scheduler_libprocess.cpp <https://reviews.apache.org/r/22539/#comment82621> Describe what you are printing. Also include Offer id. src/examples/low_level_scheduler_libprocess.cpp <https://reviews.apache.org/r/22539/#comment82622> s/task_info/taskInfo/ src/examples/low_level_scheduler_libprocess.cpp <https://reviews.apache.org/r/22539/#comment82623> end the comment with period. src/examples/low_level_scheduler_libprocess.cpp <https://reviews.apache.org/r/22539/#comment82615> Can this be const? src/tests/examples_tests.cpp <https://reviews.apache.org/r/22539/#comment82624> s/Libprocess// src/tests/examples_tests.cpp <https://reviews.apache.org/r/22539/#comment82625> s/libprocess// - Vinod Kone On June 27, 2014, 12:47 p.m., Zuyu Zhang wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/22539/ > ----------------------------------------------------------- > > (Updated June 27, 2014, 12:47 p.m.) > > > Review request for mesos, Benjamin Hindman, Ben Mahler, and Vinod Kone. > > > Repository: mesos-git > > > Description > ------- > > Add the low level scheduler example using libprocess > > > Diffs > ----- > > src/Makefile.am 902792782e760d5e0a73fb7aa72aef003c0af9c0 > src/examples/low_level_scheduler_libprocess.cpp PRE-CREATION > src/tests/examples_tests.cpp 34f0233aca3433faba7528ac8c354100b8d3a4f7 > src/tests/low_level_scheduler_libprocess_test.sh PRE-CREATION > > Diff: https://reviews.apache.org/r/22539/diff/ > > > Testing > ------- > > [==========] Running 1 test from 1 test case. > [----------] Global test environment set-up. > [----------] 1 test from ExamplesTest > [ RUN ] ExamplesTest.LowLevelSchedulerLibprocess > [ OK ] ExamplesTest.LowLevelSchedulerLibprocess (1670 ms) > [----------] 1 test from ExamplesTest (1670 ms total) > > [----------] Global test environment tear-down > [==========] 1 test from 1 test case ran. (1684 ms total) > [ PASSED ] 1 test. > > > Thanks, > > Zuyu Zhang > >
