+1 DataBuffer. Regards, Rodrigo
On 9/17/07, Jeff Genender <[EMAIL PROTECTED]> wrote: > > +1...renaming it would be good. When I explain it...I have to be very > careful in saying "I mean Mina's ByteBuffer..not a regular ByteBuffer" > > Jeff > > Trustin Lee wrote: > > Hi folks, > > > > It is often confusing to discriminate MINA ByteBuffer and NIO > > ByteBuffer. Do we need renaming? I didn't have much difficulties > > actually because most Java code doesn't use both types at the same > > time. > > > > There was an opinion about renaming it to MinaByteBuffer, but I don't > > think it's the best name available for us. I think DataBuffer, > > ExtendedByteBuffer, ExtendedBuffer or just Buffer might also be a > > candidate. There's Buffer in NIO, too, but nobody uses that class > > directly. > > > > I'd like to find the best name; short and not confusing one. Please > > don't hesitate to respond to this message with your idea so we can > > find out the best alternative. > > > > Trustin > -- If Jack Bauer had been a Spartan, the movie would have been called "1".