-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/47837/#review144833
-----------------------------------------------------------




core/src/test/java/org/apache/oozie/lock/TestMemoryLocks.java (line 342)
<https://reviews.apache.org/r/47837/#comment210972>

    Can you elabrote more?



core/src/test/java/org/apache/oozie/lock/TestMemoryLocks.java (line 350)
<https://reviews.apache.org/r/47837/#comment210970>

    Agree that System.gc() is not reliable. That is one the reason I tested the 
case in a loop for 100 time, and I didn't saw any failure.
    Our goal is not to check weak functionality of MapMaker. It's guarantee 
that weak value will get reclaimed after GC.
    
    This test case is to make sure that we don't mess up with lock entry.
    Currently, map has InterProcessReadWriteLock; we want to make sure that 
when we release, InterProcessReadWriteLock is set to null, not write or read 
lock.



core/src/test/java/org/apache/oozie/lock/TestMemoryLocks.java (line 372)
<https://reviews.apache.org/r/47837/#comment210971>

    We have been following _ naming for a long time. If you look at other test 
cases, not test function start with an underscore. But I agree that
    chcekLockRelease is a better name.


- Purshotam Shah


On Aug. 3, 2016, 4:56 p.m., Purshotam Shah wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/47837/
> -----------------------------------------------------------
> 
> (Updated Aug. 3, 2016, 4:56 p.m.)
> 
> 
> Review request for oozie.
> 
> 
> Bugs: OOZIE-2501
>     https://issues.apache.org/jira/browse/OOZIE-2501
> 
> 
> Repository: oozie-git
> 
> 
> Description
> -------
> 
> OOZIE-2501 ZK reentrant lock doesn't work for few cases
> 
> 
> Diffs
> -----
> 
>   core/src/main/java/org/apache/oozie/command/wf/ActionStartXCommand.java 
> 41f4430f69cb7a9b132a4000c3e5c8aa7573c0a0 
>   core/src/main/java/org/apache/oozie/lock/MemoryLocks.java 
> 7d65ac0e24a62086732ec91fc24f89b62469451d 
>   core/src/main/java/org/apache/oozie/service/MemoryLocksService.java 
> d7c6a89fd47a219b2ec8ea4fe0caf05dc008943b 
>   core/src/main/java/org/apache/oozie/service/ZKLocksService.java 
> 952b90d5dfbfeccf4600238f75885c792709ffc7 
>   core/src/test/java/org/apache/oozie/lock/TestMemoryLocks.java 
> 61fec19b346748b22df1b58f014c32b1c04c8c1f 
>   core/src/test/java/org/apache/oozie/service/TestZKLocksService.java 
> d1acadfff36fff637fb9ccb8e3feffb24248c792 
> 
> Diff: https://reviews.apache.org/r/47837/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Purshotam Shah
> 
>

Reply via email to