Doug MacEachern wrote:
> On Fri, 21 Sep 2001, Stas Bekman wrote:
>
>
>>patch:
>> - allows to have more than one identical directive in the __DATA__
>> section of the response handlers in tests, but turning a list into HoL
>>
>
> great. can we come up with a better name than L2HoL though?
> even list_to_hash_of_lists is fine.
sure, I just thought that HoL and LoH are quite known concepts :) Will give it a nice
name.
>> - allows a new virtual block <Base></Base> if the test wants to plant
>> something into the base level configuration
>
> i thought we planned to remove the magic that inserts test .pm config into
> a Location and instead put all .pm config in the base but support
> <Location> and <Location __PACKAGE__> ?
Hmm, we have discussed this yes. But haven't done anything about it. So
should I fix this to remove the magic and patch all the tests (including
httpd-test...)? It's hard to see the big picture, and all possible
demands that can come up. That's why a few weeks ago I've sent a patch
that declares at the first line of __DATA__ section whether the
following config sections should be interpreted as is or the magic
wrapping should happen?
I suppose that explicit configuration is easier to understand. But
changing all the tests....
> in any case, can you commit the support for multi same-name directives
> first? like to keep features as separate patches in cvs when possible.
Yup, will try to send shorter patches next time.
_____________________________________________________________________
Stas Bekman JAm_pH -- Just Another mod_perl Hacker
http://stason.org/ mod_perl Guide http://perl.apache.org/guide
mailto:[EMAIL PROTECTED] http://apachetoday.com http://eXtropia.com/
http://singlesheaven.com http://perl.apache.org http://perlmonth.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]