On Thu, 2003-06-19 at 14:21, Stas Bekman wrote:
Philippe M. Chiasson wrote:
Following the discussion on Apache::Reload and Apache::Symbol, I've taken out Apache::Symbol::undef from mp1, massaged it a bit and made it into ModPerl::Util::undef for mod_perl 2.
Works wonders when you want to undefine subroutines, constant or not, with or without prototypes. Very usefull for Apache::Reload (can get rid of that $SIG{__WARN__} trap).
As suggested in the other thread, ModPerl::Util::undef is not the best choice for the name. Me thinking either call ModPerl::Util::symbol_undef or have further subclassing: ModPerl::Util::Symbol::undef
How about like I said before ModPerl::Util::undef_code since it works only on CODE refs?
but we might have others as well, so a more generic name is better, no? symbol_undef_code? just in case?
Otherwise +1, but again please first ask Doug why hasn't he ported this code in first place.
Will do ;-)
__________________________________________________________________ Stas Bekman JAm_pH ------> Just Another mod_perl Hacker http://stason.org/ mod_perl Guide ---> http://perl.apache.org mailto:[EMAIL PROTECTED] http://use.perl.org http://apacheweek.com http://modperlbook.org http://apache.org http://ticketmaster.com
--
__________________________________________________________________ Stas Bekman JAm_pH ------> Just Another mod_perl Hacker http://stason.org/ mod_perl Guide ---> http://perl.apache.org mailto:[EMAIL PROTECTED] http://use.perl.org http://apacheweek.com http://modperlbook.org http://apache.org http://ticketmaster.com
--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]
