There is still an instance of "io.prediction" that is not changed to
"org.apache.predictionio"
in your "libraryDependencies".

Tom

On Wed, Oct 12, 2016 at 2:06 PM, Jim Miller <jemiller1...@gmail.com> wrote:

> Thanks for the fast response, Donald. I am still having problems tho.  I
> have the output and the build.sbt below.
>
>
> vagrant:tapster-episode-similar2/ $ pio build
>
>
> [INFO] [Console$] Using command 
> '/home/vagrant/apache-predictionio-0.10.0-incubating/sbt/sbt'
> at the current working directory to build.
> [INFO] [Console$] If the path above is incorrect, this process will fail.
> [INFO] [Console$] Uber JAR disabled. Making sure 
> lib/pio-assembly-0.10.0-incubating.jar
> is absent.
> [INFO] [Console$] Going to run: 
> /home/vagrant/apache-predictionio-0.10.0-incubating/sbt/sbt
>  package assemblyPackageDependency
> [ERROR] [Console$] [error] (*:update) sbt.ResolveException: unresolved
> dependency: io.prediction#apache-predictionio-core_2.10;0.10.0-incubating:
> not found
> [ERROR] [Console$] [error] Total time: 17 s, completed Oct 12, 2016
> 3:05:54 PM
> [ERROR] [Console$] Return code of previous step is 1. Aborting.
>
>
> build.sbt
> import AssemblyKeys._
>
> assemblySettings
>
> name := "template-scala-parallel-similarproduct"
>
> organization := "org.apache.predictionio"
>
> parallelExecution in Test := false
>
> test in assembly := {}
>
> libraryDependencies ++= Seq(
>   "io.prediction"    %% "apache-predictionio-core"          %
> pioVersion.value % "provided",
>   "org.apache.spark" %% "spark-core"    % "1.3.0" % "provided",
>   "org.apache.spark" %% "spark-mllib"   % "1.3.0" % "provided",
>   "org.scalatest"    %% "scalatest"     % "2.2.1" % "test")
>
>
> Thanks,
>
> Jim
>
>
> --
> Jim Miller
>
> On October 12, 2016 at 3:58:56 PM, Donald Szeto (don...@apache.org) wrote:
>
> Hi Jim,
>
> Please open up build.sbt and update:
>
> io.prediction -> org.apache.predictionio
> core -> apache-predictionio-core
>
> This should unblock your build.
>
> Regards,
> Donald
>
> On Wednesday, October 12, 2016, Jim Miller <jemiller1...@gmail.com> wrote:
>
> > Hi all,
> >
> > I am getting this error while trying out the Tapster Demo. From this
> > output can you lead me in the right direction?
> >
> >
> > vagrant:tapster-episode-similar/ $ pio build
> >
> >
> > [INFO] [Console$] Using command '/home/vagrant/apache-
> predictionio-0.10.0-incubating/sbt/sbt'
> > at the current working directory to build.
> > [INFO] [Console$] If the path above is incorrect, this process will fail.
> > [INFO] [Console$] Uber JAR disabled. Making sure lib/pio-assembly-0.10.0-
> incubating.jar
> > is absent.
> > [INFO] [Console$] Going to run: /home/vagrant/apache-
> predictionio-0.10.0-incubating/sbt/sbt
> > package assemblyPackageDependency
> > [ERROR] [Console$] [error] (*:update) sbt.ResolveException: unresolved
> > dependency: io.prediction#core_2.10;0.10.0-incubating: not found
> > [ERROR] [Console$] [error] Total time: 28 s, completed Oct 12, 2016
> > 11:35:33 AM
> > [ERROR] [Console$] Return code of previous step is 1. Aborting.
> >
> >
> > Thanks,
> >
> > Jim
> >
> >
> >
> > --
> > Jim Miller
> >
>

Reply via email to