vagrant:tapster-episode-similar2/ $ pio build --verbose                         
                                                                                
                                                                     [20:46:39]
[INFO] [Console$] Using existing engine manifest JSON at 
/home/vagrant/apache-predictionio-0.10.0-incubating/tapster-episode-similar2/manifest.json
[INFO] [Console$] Using command 
'/home/vagrant/apache-predictionio-0.10.0-incubating/sbt/sbt' at the current 
working directory to build.
[INFO] [Console$] If the path above is incorrect, this process will fail.
[INFO] [Console$] Uber JAR disabled. Making sure 
lib/pio-assembly-0.10.0-incubating.jar is absent.
[INFO] [Console$] Going to run: 
/home/vagrant/apache-predictionio-0.10.0-incubating/sbt/sbt  package 
assemblyPackageDependency
[INFO] [Console$] [info] Loading project definition from 
/home/vagrant/apache-predictionio-0.10.0-incubating/tapster-episode-similar2/project
[ERROR] [Console$] 
/home/vagrant/apache-predictionio-0.10.0-incubating/tapster-episode-similar2/pio.sbt:4:
 error: not found: value pioVersion
[ERROR] [Console$] pioVersion := "0.10.0-incubating"
[ERROR] [Console$] ^
[INFO] [Console$] [error] Type error in expression
[INFO] [Console$] Project loading failed: (r)etry, (q)uit, (l)ast, or (i)gnore?
[ERROR] [Console$] Return code of previous step is 1. Aborting.

-- 
Jim Miller

On October 12, 2016 at 11:09:48 PM, Donald Szeto (donald.sz...@gmail.com) wrote:

Can you try "pio build --verbose" for detail error?  

On Wednesday, October 12, 2016, Jim Miller <jemiller1...@gmail.com> wrote:  

> I think we’re closer, Donald.  
>  
> ************************************************************  
> ****************************************************  
> build.sbt  
> import AssemblyKeys._  
>  
> assemblySettings  
>  
> name := "template-scala-parallel-similarproduct"  
>  
> organization := "org.apache.predictionio"  
>  
> parallelExecution in Test := false  
>  
> test in assembly := {}  
>  
> libraryDependencies ++= Seq(  
> "org.apache.predictionio" %% "apache-predictionio-core" %  
> "0.10.0-incubating" % "provided",  
> "org.apache.spark" %% "spark-core" % "1.3.0" % "provided",  
> "org.apache.spark" %% "spark-mllib" % "1.3.0" % "provided",  
> "org.scalatest" %% "scalatest" % "2.2.1" % "test”)  
> ************************************************************  
> ***************************************************  
> ERROR  
> vagrant:tapster-episode-similar2/ $ pio build  
>  
>  
> [19:46:57]  
> [INFO] [Console$] Using existing engine manifest JSON at  
> /home/vagrant/apache-predictionio-0.10.0-incubating/tapster-episode-  
> similar2/manifest.json  
> [INFO] [Console$] Using command 
> '/home/vagrant/apache-predictionio-0.10.0-incubating/sbt/sbt'  
> at the current working directory to build.  
> [INFO] [Console$] If the path above is incorrect, this process will fail.  
> [INFO] [Console$] Uber JAR disabled. Making sure 
> lib/pio-assembly-0.10.0-incubating.jar  
> is absent.  
> [INFO] [Console$] Going to run: 
> /home/vagrant/apache-predictionio-0.10.0-incubating/sbt/sbt  
> package assemblyPackageDependency  
> [ERROR] [Console$] [error] Type error in expression  
> [ERROR] [Console$] Return code of previous step is 1. Aborting.  
>  
> --  
> Jim Miller  
>  
> On October 12, 2016 at 9:19:32 PM, Donald Szeto (don...@apache.org  
> <javascript:;>) wrote:  
>  
> I think the build plugin is really confusing. Sorry but let's do this:  
>  
> 1. Remove project/pio-build.sbt completely.  
> 2. Replace pioVersion.value with 0.10.0-incubating in build.sbt.  
>  
> That should be it. We are in the process of updating all templates post  
> Apache transition.  
>  
> On Wednesday, October 12, 2016, Jim Miller <jemiller1...@gmail.com  
> <javascript:;>> wrote:  
>  
> > Tom,  
> >  
> > I only found one spot in the pio-build.sbt with 0.9.0 and changed to  
> > 0.10.0 but with the following errors:  
> >  
> > vagrant:tapster-episode-similar2/ $ pio build  
> >  
> >  
> > [18:20:21]  
> > [INFO] [Console$] Using existing engine manifest JSON at  
> > /home/vagrant/apache-predictionio-0.10.0-incubating/tapster-episode-  
> > similar2/manifest.json  
> > [INFO] [Console$] Using command '/home/vagrant/apache-  
> predictionio-0.10.0-incubating/sbt/sbt'  
> > at the current working directory to build.  
> > [INFO] [Console$] If the path above is incorrect, this process will fail.  
> > [INFO] [Console$] Uber JAR disabled. Making sure lib/pio-assembly-0.10.0-  
> incubating.jar  
> > is absent.  
> > [INFO] [Console$] Going to run: /home/vagrant/apache-  
> predictionio-0.10.0-incubating/sbt/sbt  
> > package assemblyPackageDependency  
> > [ERROR] [Console$] [error] (*:update) sbt.ResolveException: unresolved  
> > dependency: org.apache.predictionio#pio-build;0.10.0: not found  
> > [ERROR] [Console$] Return code of previous step is 1. Aborting.  
> >  
> > --  
> > Jim Miller  
> >  
> > On October 12, 2016 at 8:16:32 PM, Tom Chan (yukhei.c...@gmail.com  
> <javascript:;>  
> > <javascript:;>) wrote:  
> >  
> > I spotted "0.9.0" in the log. Can you replace that with 0.10.0 as you  
> find  
> > them?  
> >  
> > Tom  
> >  
> > On Wed, Oct 12, 2016 at 5:01 PM, Jim Miller <jemiller1...@gmail.com  
> <javascript:;>  
> > <javascript:;>> wrote:  
> >  
> > > Hi Tom,  
> > >  
> > > I’ve made changes to the following:  
> > >  
> > > tapster-episode-similar2/src/main/scala/CooccurrenceAlgorithm.scala  
> > > tapster-episode-similar2/src/main/scala/Preparator.scala  
> > > tapster-episode-similar2/src/main/scala/Serving.scala  
> > > tapster-episode-similar2/src/main/scala/Engine.scala  
> > > tapster-episode-similar2/src/main/scala/ALSAlgorithm.scala  
> > >  
> > > Now with these ERRORS:  
> > > vagrant:tapster-episode-similar2/ $ pio build  
> > >  
> > >  
> > > [17:41:09]  
> > > [INFO] [Console$] Using existing engine manifest JSON at  
> > > /home/vagrant/apache-predictionio-0.10.0-incubating/tapster-episode-  
> > > similar2/manifest.json  
> > > [INFO] [Console$] Using command '/home/vagrant/apache-  
> > predictionio-0.10.0-incubating/sbt/sbt'  
> > > at the current working directory to build.  
> > > [INFO] [Console$] If the path above is incorrect, this process will  
> fail.  
> > > [INFO] [Console$] Uber JAR disabled. Making sure  
> lib/pio-assembly-0.10.0-  
> > incubating.jar  
> > > is absent.  
> > > [INFO] [Console$] Going to run: /home/vagrant/apache-  
> > predictionio-0.10.0-incubating/sbt/sbt  
> > > package assemblyPackageDependency  
> > > [ERROR] [Console$] [error] (*:update) sbt.ResolveException: unresolved  
> > > dependency: org.apache.predictionio#pio-build;0.9.0: not found  
> > > [ERROR] [Console$] Return code of previous step is 1. Aborting.  
> > >  
> > > Thanks,  
> > >  
> > > Jim  
> > >  
> > >  
> > > --  
> > > Jim Miller  
> > >  
> > > On October 12, 2016 at 6:24:23 PM, Tom Chan (yukhei.c...@gmail.com  
> <javascript:;>  
> > <javascript:;>) wrote:  
> > >  
> > > I think everything "io.prediction" in the template (imports) need to be  
> > > changed to "org.apache.predictionio" as well.  
> > >  
> > > After that it should compile.  
> > >  
> > > Tom  
> > >  
> > > On Wed, Oct 12, 2016 at 3:19 PM, Jim Miller <jemiller1...@gmail.com  
> <javascript:;>  
> > <javascript:;>>  
> > > wrote:  
> > >  
> > > > Thanks Tom. I’ve made the change and now I have another set of  
> errors.  
> > > >  
> > > > ************************************************************  
> > > > ********************  
> > > > build.sbt  
> > > > import AssemblyKeys._  
> > > >  
> > > > assemblySettings  
> > > >  
> > > > name := "template-scala-parallel-similarproduct"  
> > > >  
> > > > organization := "org.apache.predictionio"  
> > > >  
> > > > parallelExecution in Test := false  
> > > >  
> > > > test in assembly := {}  
> > > >  
> > > > libraryDependencies ++= Seq(  
> > > > "org.apache.predictionio" %% "apache-predictionio-core" %  
> > > > pioVersion.value % "provided",  
> > > > "org.apache.spark" %% "spark-core" % "1.3.0" % "provided",  
> > > > "org.apache.spark" %% "spark-mllib" % "1.3.0" % "provided",  
> > > > "org.scalatest" %% "scalatest" % "2.2.1" % "test")—  
> > > >  
> > > > ************************************************************  
> > > > *********************  
> > > >  
> > > > ERRORS  
> > > > vagrant:tapster-episode-similar2/ $ pio build  
> > > >  
> > > >  
> > > > [16:11:22]  
> > > > [INFO] [Console$] Using existing engine manifest JSON at  
> > > > /home/vagrant/apache-predictionio-0.10.0-incubating/tapster-episode-  
> > > > similar2/manifest.json  
> > > > [INFO] [Console$] Using command '/home/vagrant/apache-  
> > > predictionio-0.10.0-incubating/sbt/sbt'  
> > > > at the current working directory to build.  
> > > > [INFO] [Console$] If the path above is incorrect, this process will  
> > fail.  
> > > > [INFO] [Console$] Uber JAR disabled. Making sure  
> > lib/pio-assembly-0.10.0-  
> > > incubating.jar  
> > > > is absent.  
> > > > [INFO] [Console$] Going to run: /home/vagrant/apache-  
> > > predictionio-0.10.0-incubating/sbt/sbt  
> > > > package assemblyPackageDependency  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > ALSAlgorithm.scala:3:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.  
> > P2LAlgorithm  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > ALSAlgorithm.scala:4:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.Params  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > ALSAlgorithm.scala:5:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.data.storage.BiMap  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > ALSAlgorithm.scala:20:  
> > > > not found: type Params  
> > > > [ERROR] [Console$] [error] seed: Option[Long]) extends Params  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > ALSAlgorithm.scala:24:  
> > > > not found: type BiMap  
> > > > [ERROR] [Console$] [error] val itemStringIntMap: BiMap[String, Int],  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > ALSAlgorithm.scala:44:  
> > > > not found: type P2LAlgorithm  
> > > > [ERROR] [Console$] [error] extends P2LAlgorithm[PreparedData,  
> ALSModel,  
> > > > Query, PredictedResult] {  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > ALSAlgorithm.scala:62:  
> > > > not found: value BiMap  
> > > > [ERROR] [Console$] [error] val userStringIntMap =  
> > > > BiMap.stringInt(data.users.keys)  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > ALSAlgorithm.scala:63:  
> > > > not found: value BiMap  
> > > > [ERROR] [Console$] [error] val itemStringIntMap =  
> > > > BiMap.stringInt(data.items.keys)  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > ALSAlgorithm.scala:68:  
> > > > value collectAsMap is not a member of org.apache.spark.rdd.RDD[U]  
> > > > [ERROR] [Console$] [error] possible cause: maybe a semicolon is  
> missing  
> > > > before `value collectAsMap'?  
> > > > [ERROR] [Console$] [error] }.collectAsMap.toMap  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > ALSAlgorithm.scala:85:  
> > > > missing parameter type for expanded function  
> > > > [ERROR] [Console$] [error] The argument types of an anonymous  
> function  
> > > > must be fully known. (SLS 8.5)  
> > > > [ERROR] [Console$] [error] Expected type was: ? => Boolean  
> > > > [ERROR] [Console$] [error] }.filter { case ((u, i), v) =>  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > CooccurrenceAlgorithm.scala:3:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.  
> > P2LAlgorithm  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > CooccurrenceAlgorithm.scala:4:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.Params  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > CooccurrenceAlgorithm.scala:5:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.data.storage.BiMap  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > > CooccurrenceAlgorithm.scala:12: not found: type Params  
> > > > [ERROR] [Console$] [error] ) extends Params  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > > CooccurrenceAlgorithm.scala:16: not found: type BiMap  
> > > > [ERROR] [Console$] [error] val itemStringIntMap: BiMap[String, Int],  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > > CooccurrenceAlgorithm.scala:28: not found: type P2LAlgorithm  
> > > > [ERROR] [Console$] [error] extends P2LAlgorithm[PreparedData,  
> > > > CooccurrenceModel, Query, PredictedResult] {  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > > CooccurrenceAlgorithm.scala:32: not found: value BiMap  
> > > > [ERROR] [Console$] [error] val itemStringIntMap =  
> > > > BiMap.stringInt(data.items.keys)  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > > CooccurrenceAlgorithm.scala:57: not found: type BiMap  
> > > > [ERROR] [Console$] [error] itemStringIntMap: BiMap[String, Int]):  
> > > > Map[Int, Array[(Int, Int)]] = {  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > > CooccurrenceAlgorithm.scala:43: value collectAsMap is not a member  
> of  
> > > > org.apache.spark.rdd.RDD[U]  
> > > > [ERROR] [Console$] [error] possible cause: maybe a semicolon is  
> missing  
> > > > before `value collectAsMap'?  
> > > > [ERROR] [Console$] [error] }.collectAsMap.toMap  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > > > CooccurrenceAlgorithm.scala:70: value join is not a member of  
> > > > org.apache.spark.rdd.RDD[Nothing]  
> > > > [ERROR] [Console$] [error] val cooccurrences: RDD[((Int, Int), Int)]  
> =  
> > > > userItem.join(userItem)  
> > > > [ERROR] [Console$] [error]  
> > > > ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> DataSource.scala:3:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.  
> PDataSource  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> DataSource.scala:4:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.  
> > > > EmptyEvaluationInfo  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> DataSource.scala:5:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.  
> > > > EmptyActualResult  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> DataSource.scala:6:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.Params  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> DataSource.scala:7:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.data.storage.Event  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> DataSource.scala:8:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.data.store.  
> PEventStore  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > DataSource.scala:16:  
> > > > not found: type Params  
> > > > [ERROR] [Console$] [error] case class DataSourceParams(appName:  
> String)  
> > > > extends Params  
> > > > [ERROR] [Console$] [error]  
> > > > ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > DataSource.scala:19:  
> > > > not found: type PDataSource  
> > > > [ERROR] [Console$] [error] extends PDataSource[TrainingData,  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > DataSource.scala:28:  
> > > > not found: value PEventStore  
> > > > [ERROR] [Console$] [error] val usersRDD: RDD[(String, User)] =  
> > > > PEventStore.aggregateProperties(  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > DataSource.scala:45:  
> > > > not found: value PEventStore  
> > > > [ERROR] [Console$] [error] val itemsRDD: RDD[(String, Item)] =  
> > > > PEventStore.aggregateProperties(  
> > > >  
> > > > ▽  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > DataSource.scala:63:  
> > > > not found: value PEventStore  
> > > > [ERROR] [Console$] [error] val viewEventsRDD: RDD[ViewEvent] =  
> > > > PEventStore.find(  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/Engine.scala:3:  
> > > object  
> > > > prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.  
> > > IEngineFactory  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/Engine.scala:4:  
> > > object  
> > > > prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.Engine  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/Engine.scala:25:  
> > not  
> > > > found: type IEngineFactory  
> > > > [ERROR] [Console$] [error] object SimilarProductEngine extends  
> > > > IEngineFactory {  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/Engine.scala:27:  
> > not  
> > > > found: type Engine  
> > > > [ERROR] [Console$] [error] new Engine(  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> Preparator.scala:3:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.  
> PPreparator  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/  
> > Preparator.scala:10:  
> > > > not found: type PPreparator  
> > > > [ERROR] [Console$] [error] extends PPreparator[TrainingData,  
> > > > PreparedData] {  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/Serving.scala:3:  
> > > > object prediction is not a member of package io  
> > > > [ERROR] [Console$] [error] import io.prediction.controller.LServing  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] /home/vagrant/apache-predictionio-0.10.0-  
> > > > incubating/tapster-episode-similar2/src/main/scala/Serving.scala:6:  
> > not  
> > > > found: type LServing  
> > > > [ERROR] [Console$] [error] extends LServing[Query, PredictedResult] {  
> > > > [ERROR] [Console$] [error] ^  
> > > > [ERROR] [Console$] [error] 39 errors found  
> > > > [ERROR] [Console$] [error] (compile:compile) Compilation failed  
> > > > [ERROR] [Console$] [error] Total time: 21 s, completed Oct 12, 2016  
> > > > 4:11:55 PM  
> > > > [ERROR] [Console$] Return code of previous step is 1. Aborting.  
> > > > Jim Miller  
> > > >  
> > > > On October 12, 2016 at 5:27:48 PM, Tom Chan (yukhei.c...@gmail.com  
> <javascript:;>  
> > <javascript:;>)  
> > > wrote:  
> > > >  
> > > > There is still an instance of "io.prediction" that is not changed to  
> > > > "org.apache.predictionio"  
> > > > in your "libraryDependencies".  
> > > >  
> > > > Tom  
> > > >  
> > > > On Wed, Oct 12, 2016 at 2:06 PM, Jim Miller <jemiller1...@gmail.com  
> <javascript:;>  
> > <javascript:;>>  
> > > > wrote:  
> > > >  
> > > > > Thanks for the fast response, Donald. I am still having problems  
> > tho. I  
> > > > > have the output and the build.sbt below.  
> > > > >  
> > > > >  
> > > > > vagrant:tapster-episode-similar2/ $ pio build  
> > > > >  
> > > > >  
> > > > > [INFO] [Console$] Using command '/home/vagrant/apache-  
> > > > predictionio-0.10.0-incubating/sbt/sbt'  
> > > > > at the current working directory to build.  
> > > > > [INFO] [Console$] If the path above is incorrect, this process will  
> > > fail.  
> > > > > [INFO] [Console$] Uber JAR disabled. Making sure  
> > > lib/pio-assembly-0.10.0-  
> > > > incubating.jar  
> > > > > is absent.  
> > > > > [INFO] [Console$] Going to run: /home/vagrant/apache-  
> > > > predictionio-0.10.0-incubating/sbt/sbt  
> > > > > package assemblyPackageDependency  
> > > > > [ERROR] [Console$] [error] (*:update) sbt.ResolveException:  
> > unresolved  
> > > > > dependency: io.prediction#apache-predictionio-core_2.10;0.10.0-  
> > > > incubating:  
> > > > > not found  
> > > > > [ERROR] [Console$] [error] Total time: 17 s, completed Oct 12, 2016  
> > > > > 3:05:54 PM  
> > > > > [ERROR] [Console$] Return code of previous step is 1. Aborting.  
> > > > >  
> > > > >  
> > > > > build.sbt  
> > > > > import AssemblyKeys._  
> > > > >  
> > > > > assemblySettings  
> > > > >  
> > > > > name := "template-scala-parallel-similarproduct"  
> > > > >  
> > > > > organization := "org.apache.predictionio"  
> > > > >  
> > > > > parallelExecution in Test := false  
> > > > >  
> > > > > test in assembly := {}  
> > > > >  
> > > > > libraryDependencies ++= Seq(  
> > > > > "io.prediction" %% "apache-predictionio-core" %  
> > > > > pioVersion.value % "provided",  
> > > > > "org.apache.spark" %% "spark-core" % "1.3.0" % "provided",  
> > > > > "org.apache.spark" %% "spark-mllib" % "1.3.0" % "provided",  
> > > > > "org.scalatest" %% "scalatest" % "2.2.1" % "test")  
> > > > >  
> > > > >  
> > > > > Thanks,  
> > > > >  
> > > > > Jim  
> > > > >  
> > > > >  
> > > > > --  
> > > > > Jim Miller  
> > > > >  
> > > > > On October 12, 2016 at 3:58:56 PM, Donald Szeto (don...@apache.org  
> <javascript:;>  
> > <javascript:;>)  
> > > > wrote:  
> > > > >  
> > > > > Hi Jim,  
> > > > >  
> > > > > Please open up build.sbt and update:  
> > > > >  
> > > > > io.prediction -> org.apache.predictionio  
> > > > > core -> apache-predictionio-core  
> > > > >  
> > > > > This should unblock your build.  
> > > > >  
> > > > > Regards,  
> > > > > Donald  
> > > > >  
> > > > > On Wednesday, October 12, 2016, Jim Miller <jemiller1...@gmail.com  
> <javascript:;>  
> > <javascript:;>>  
> > > > wrote:  
> > > > >  
> > > > > > Hi all,  
> > > > > >  
> > > > > > I am getting this error while trying out the Tapster Demo. From  
> > this  
> > > > > > output can you lead me in the right direction?  
> > > > > >  
> > > > > >  
> > > > > > vagrant:tapster-episode-similar/ $ pio build  
> > > > > >  
> > > > > >  
> > > > > > [INFO] [Console$] Using command '/home/vagrant/apache-  
> > > > > predictionio-0.10.0-incubating/sbt/sbt'  
> > > > > > at the current working directory to build.  
> > > > > > [INFO] [Console$] If the path above is incorrect, this process  
> will  
> > > > fail.  
> > > > > > [INFO] [Console$] Uber JAR disabled. Making sure  
> > > > lib/pio-assembly-0.10.0-  
> > > > > incubating.jar  
> > > > > > is absent.  
> > > > > > [INFO] [Console$] Going to run: /home/vagrant/apache-  
> > > > > predictionio-0.10.0-incubating/sbt/sbt  
> > > > > > package assemblyPackageDependency  
> > > > > > [ERROR] [Console$] [error] (*:update) sbt.ResolveException:  
> > > unresolved  
> > > > > > dependency: io.prediction#core_2.10;0.10.0-incubating: not found  
> > > > > > [ERROR] [Console$] [error] Total time: 28 s, completed Oct 12,  
> 2016  
> > > > > > 11:35:33 AM  
> > > > > > [ERROR] [Console$] Return code of previous step is 1. Aborting.  
> > > > > >  
> > > > > >  
> > > > > > Thanks,  
> > > > > >  
> > > > > > Jim  
> > > > > >  
> > > > > >  
> > > > > >  
> > > > > > --  
> > > > > > Jim Miller  
> > > > > >  
> > > > >  
> > > >  
> > >  
> >  
>  

Reply via email to