On Tue, 2010-05-11, Greg Stein wrote:
> On Tue, May 11, 2010 at 14:29,  <julianf...@apache.org> wrote:
> > Author: julianfoad
> > Date: Tue May 11 18:29:11 2010
> > New Revision: 943219
> >
> > URL: http://svn.apache.org/viewvc?rev=943219&view=rev
> > Log:
> > * subversion/libsvn_wc/update_editor.c
> >  (choose_base_paths): Rename to get_pristine_base_path; update doc string.
> >  (get_revert_base_checksum): Rename to get_pristine_base_checksum.
> >  (apply_textdelta, close_file): Adjust callers.
> 
> How is "pristine base" different from simply talking about the BASE
> tree? Seems like you're introducing redundant terms.

I was trying to do two things: avoid using plain "base" because in
traditional usage (which is still widespread) it means "WORKING_NODE if
present else BASE_NODE"; and also identify that it refers to the *text*
of the BASE_NODE rather than, say, its properties.

Thinking about this now, "text" would be better than "pristine", so I
propose "get_base_text_{checksum,path}", or even
"get_base_node_text_{checksum,path}".

Actually I intend to replace these local functions with one or more
library-scope functions, perhaps like

  svn_wc__get_base_node_text_info(OUT abspath,
                                  OUT sha1_checksum,
                                  OUT md5_checksum,
                                  OUT file_size,
                                  IN db, local_abspath, pools);

where the OUT params are optional outputs.  Any comments on that?

- Julian


Reply via email to