Jesang Yoon created ZEPPELIN-1554:
-------------------------------------

             Summary: Update jekyll version of https://zeppelin.apache.org/docs 
from v1 to v3 
                 Key: ZEPPELIN-1554
                 URL: https://issues.apache.org/jira/browse/ZEPPELIN-1554
             Project: Zeppelin
          Issue Type: Improvement
          Components: documentation
            Reporter: Jesang Yoon
            Priority: Minor


I found https://zeppelin.apache.org/docs uses old jekyll v1 version while 
working on the doc to support i18n for the docs and also found the version 
needs to be updated at least greater than v2 or even v3 since minimal 
requirements for the jekyll plugins for i18n is v2 and recommended is v3.

https://github.com/Anthony-Gaudino/jekyll-multiple-languages-plugin
https://github.com/vwochnik/jekyll-language-plugin
https://github.com/untra/polyglot

So If commiters and PMC doesn't mind to update the version of jekyll for the 
documentation, I'll trying to PR the my working update to github. Since jekyll 
v3 only supports kramdown instead of redcarpet, some glitches found after the 
update but I can fix that.

Please comment :)




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to