As many of you know, every year we (the GCC team) rebuild all the Fedora
packages with the upcoming GCC, so as to reveal as many bugs as possible before
we release the new version.  As in the previous years, it is only performed on
x86_64 only; we unfortunately lack the resources to deal with other arches.
Ideally we'd conclude this mass rebuild *before* the new GCC has gotten into
the buildroots; alas, this wasn't the case this year.

I downloaded all Fedora packages on Jan 19, which should give you a sense of
how long it takes to process all of this.
There were 20892 packages overall (last year Fedora had 18811 packages).  Using
koji-is-noarch.py I removed all noarch packages from that, so that we only
build archful packages to save time.  That left me with 9329 packages to build.
Of that, 8358 built fine with the new GCC (mostly gcc-8.0.1-0.3.fc28.x86_64.rpm
but I also used a newer version from rawhide).  The packages that failed to
build with GCC 8 I rebuilt with GCC 7; if they failed with GCC 7, I took them
off the list.  The rest had to be analyzed; it was around 300 packages this
time.  (Last year it was ~198 packages.  So more work this year.)

I found several GCC bugs, most of which have already been fixed (actually all
but PR84231).  Fortran ABI has changed in GCC 8 (as it did in GCC 7).  A nasty
bug has been discovered in the new empty classes ABI code: we will need another
mass rebuild to find out which package are affected.  There have been a few
bugs in code that deals with optimizing strlen; hopefully we won't find more of
them.

A lot of churn has been caused due to changes in the C++ compiler.  Previously
GCC was fairly forgiving about broken template code and would check almost
nothing until the template was instantiated.  In more recent releases parts of
the template which don't depend on the template arguments get checked earlier.
The standard says such code is ill-formed, but that no diagnostic is required
i.e.  the compiler is allowed to diagnose the problem, but not required to
(because it could be expensive or difficult to check for some compilers).  So
the code was always broken, but now GCC tells you about it.  I encourage the
packagers to fix these bugs.

With every release GCC gains new warnings which cause build failures in
packages that use -Werror (not going to start a flame war about this here).
This year the main offender was probably -Wformat-truncation.  Due to time
constrains I wasn't able to check every warning and decide if it's warranted
or a false positive.

As usual, there will be a "porting to" document to ease the transition to the
new GCC.  We already have https://gcc.gnu.org/gcc-8/porting_to.html, even though
this document is still in flux.

What follows is my analysis of what went wrong for the people who want to get
an overview of the details.  Note that my understanding of packages other than
gcc is very limited, so it's entirely possible that I miscategorized some
problems.  Since during the time I was analyzing failures GCC 8 made it to the
buildroots, it was no longer possible to use buildroots only different from
each other by the GCC version, so some of the failures are caused by a new
version of boost, glibc, etc.

Thanks Jakub Jelinek for promply fixing bugs I reported (or caused :)) and
Jonathan Wakely for his great help with anything related to C++.

Let's get down to the nitty-gritty:



apr-1.6.3-1.fc28.src.rpm
    undefined behavior -- signed overflow:
    310     for (off = 1; off < LONG_MAX && off > 0; off *= 2) {
    311         apr_strfsize(off, buf);
    312         apr_strfsize(off + 1, buf);
    313         apr_strfsize(off - 1, buf);
    314     }
    where off is of type long int.

mozjs38-38.8.0-8.fc28.src.rpm
    undefined behavior; building with -fsanitize=undefined:

    # cd /builddir/build/BUILD/mozilla-esr38/js/src/tests && 
/builddir/build/BUILD/mozilla-esr38/js/src/js/src/shell/js -f shell.js -f 
js1_5/shell.js -f js1_    5/Regress/shell.js -f 
js1_5/Regress/regress-360969-06.js; cd -
    BUGNUMBER: 360969
    STATUS: 2^17: global function
    /builddir/build/BUILD/mozilla-esr38/js/src/gc/Marking.cpp:669:10: runtime 
error: load of misaligned address 0x7f8be8070c9a for type 'void *', which 
requires 8 byte alignment
    0x7f8be8070c9a: note: pointer points here
    00 00  48 b9 30 d8 e5 e2 8b 7f  00 00 48 8b 49 70 48 8d  49 68 41 52 41 51 
41 50  57 56 52 51 50 48
              ^
    /builddir/build/BUILD/mozilla-esr38/js/src/gc/Marking.cpp:671:13: runtime 
error: load of misaligned address 0x7f8be8070c9a for type 'void *', which 
requires 8 byte alignment
    0x7f8be8070c9a: note: pointer points here
    00 00  48 b9 30 d8 e5 e2 8b 7f  00 00 48 8b 49 70 48 8d  49 68 41 52 41 51 
41 50  57 56 52 51 50 48
              ^
    ...and so on.
    This changed with https://gcc.gnu.org/r255387.
    With -fno-delete-null-poiner-checks this passes.

libomxil-bellagio-0.9.3-15.fc27.src.rpm
libX11-1.6.5-5.fc28.src.rpm
    error: '__builtin_strcpy' forming offset 2 is out of the bounds [0, 1] 
[-Werror=array-bounds]
    error: '__builtin_memcpy' forming offset [25, 72] is out of the bounds [0, 
24] of object 'uuid' with type 'OMX_U32[3]' {aka 'long unsigned int[3]'} 
[-Werror=array-bounds]

nasm-2.13.02-2.fc28.src.rpm
    error: 'pure' attribute on function returning 'void' [-Werror=attributes]
    GCC is more picky regarding attributes usage

byzanz-0.3-0.20.fc28.src.rpm
gdb-8.0.90.20180109-1.fc28.src.rpm
gxneur-0.20.0-1.fc28.src.rpm
insight-7.12.50.20170416-4.fc27.src.rpm
libraqm-0.1.1-4.fc27.src.rpm
lightdm-gtk-2.0.3-4.fc28.src.rpm
open62541-0.2-1.fc28.src.rpm
openvas-scanner-5.1.1-4.fc27.src.rpm
purple-telegram-1.3.1-5.fc27.src.rpm
stlink-1.4.0-2.fc28.src.rpm
v8-314-3.14.5.10-7.fc27.src.rpm
yp-tools-4.2.2-4.fc27.src.rpm
    error: cast between incompatible function types from X to Y
    [-Werror=cast-function-type]

atlascpp-0.6.4-2.fc27.src.rpm
libyui-3.3.3-1.fc28.src.rpm
pulseview-0.4.0-5.fc27.src.rpm
    error: catching polymorphic type 'class 
Atlas::Objects::DefaultLoadingException' by value [-Werror=catch-value=]
    and similar

ceph-12.2.2-1.fc28.src.rpm
leatherman-1.3.0-4.fc28.src.rpm
mellowplayer-3.2.0-1.fc28.src.rpm
spirv-tools-2016.7-0.2.20171023.git5834719.fc28.src.rpm
squid-4.0.22-1.fc28.src.rpm
    error: 'void* memset(void*, int, size_t)' clearing an object of type 
'struct std::atomic<unsigned int>' with no trivial copy-assignment; use 
value-initialization instead [-Werror=class-memaccess]
    and similar

grip-3.6.1-2.fc28.src.rpm
nss-3.34.0-2.fc28.src.rpm
    error: '%s' directive writing up to 511 bytes into a region of size 256 
[-Werror=format-overflow=]
    error: '__builtin___sprintf_chk' may write a terminating nul past the end 
of the destination [-Werror=format-overflow=]

bip-0.8.9-14.fc27.src.rpm
e2tools-0.0.16-29.fc27.src.rpm
fcoe-utils-1.0.32-3.fc27.src.rpm
frozen-bubble-2.2.1-0.22.beta1.fc28.src.rpm
giada-0.14.4-1.fc28.src.rpm
infinipath-psm-3.3-22_g4abbc60_open.5.fc28.src.rpm
libfaketime-0.9.6-6.fc27.src.rpm
liboping-1.10.0-3.fc27.src.rpm
libpfm-4.9.0-2.fc28.src.rpm
libpsm2-10.3.8-3.fc28.src.rpm
mdadm-4.0-5.fc27.src.rpm
memcached-1.5.4-1.fc28.src.rpm
openzwave-1.5.0-0.20170724gitde1c0e6.fc27.src.rpm
target-isns-0.6.2-5.fc27.src.rpm
usbip-4.14.11-1.fc28.src.rpm
wlroots-0.0.1-0.7.20180106git03faf17.fc28.src.rpm
    error: '%s' directive output may be truncated writing up to 1023 bytes into 
a region of size 1022 [-Werror=format-truncation=]
    none of these should be a false positive

flatbuffers-1.8.0-2.fc28.src.rpm
    error: type qualifiers ignored on cast result type 
[-Werror=ignored-qualifiers]

libkcapi-1.0.3-2.fc28.src.rpm
    error: this statement may fall through [-Werror=implicit-fallthrough=]

python37-3.7.0-0.2.a4.fc28.src.rpm
    error: implicit declaration of function ‘crypt’ 
[-Werror=implicit-function-declaration]
    is probably the reason why this failed

ucx-1.2.2-1.fc28.src.rpm
    error: alignment 1 of 'struct uct_ud_send_skb_inl' is less than 64
    [-Werror=packed-not-aligned]

camotics-1.1.1-9.fc27.src.rpm
usbguard-0.7.1-2.fc28.src.rpm
    error: unnecessary parentheses in declaration of 'assert_arg'
    [-Werror=parentheses]
    -Wparentheses has been enhanced, it detects redundant () e.g. here
    typedef int (Private::*Zero);

edk2-20171011git92d07e4-2.fc28.src.rpm
kernel-4.15.0-0.rc8.git0.1.fc28.src.rpm
    error: passing argument 2 to restrict-qualified parameter aliases with 
argument 4 [-Werror=restrict]
        select(1, &in, NULL, &in, NULL);
    and
    error: 'memcpy' accessing between 17 and 2147483631 bytes at offsets 16 and 
16 overlaps between 17 and 2147483631 bytes at offset 16 [-Werror=restrict]
         memcpy(copy_dst + 16, copy_src + 16, (size_t)(i - 16));

newscache-1.2-0.27.rc6.fc27.src.rpm
    a configure test uses this program:
    class Exc {
    public:
      Exc() {}
      ~Exc() {}
    };
    void t() { throw Exc(); }
    main() {
      try {
        t();
      }
      catch(Exc &e) {
      }
    }
  and it fails due to -Wreturn-type; add int to main to fix it.

scsi-target-utils-1.0.70-4.fc28.src.rpm
    error: 'strncpy' output may be truncated copying 4 bytes from a string of
    length 4 [-Werror=stringop-truncation]
    and similar

florist-2011-22.fc27.src.rpm
    gprbuild: *** compilation phase failed
    This is gcc-gnat related.  Didn't investigate further.

dssp-2.2.1-16.fc27.src.rpm
freeorion-0.4.7.1-2.fc28.src.rpm
libcutl-1.10.0-10.fc27.src.rpm
rospack-2.0.14-18.fc27.src.rpm
    fatal error: boost/tr1/tuple.hpp: No such file or directory
    error: 'boost::system::posix_error' has not been declared
    error: boost regex is not found
    fatal error: boost/tr1/unordered_set.hpp: No such file or directory
    boost-related, so didn't investigate further.

votca-xtp-1.4.1-1.fc28.src.rpm
    So boost has been updated to 1.66.  This update broke it; specifically
    this change in
    /usr/include/boost/format/feed_args.hpp (comes from
    boost-devel-1.66.0-0.1.fc28.x86_64):

      template< class Ch, class Tr, class T>
      void call_put_last(::std:: basic_ostream<Ch, Tr> & os, const void* x) {
    -        put_last(os, *(T*)x);
    +        put_last(os, *(static_cast<T const *>(x)));
       }

    caused error: no match for 'operator<<' (operand types are 
'std::basic_ostream<char>' and 'const votca::tools::Property')

rubygem-gtk2-3.2.1-2.fc28.src.rpm
rubygem-rkerberos-0.1.5-8.fc28.src.rpm
rubygem-rugged-0.26.0-4.fc28.src.rpm
    this can be boiled down to:

    const int a = 1, b;
    __attribute__((__error__("bar"))) int foo (); 

    int
    invoke_callback (void)
    {
       return __builtin_choose_expr (__builtin_constant_p (a), foo (), b); 
    }

    "a" is now constant since https://gcc.gnu.org/r254930, so the error 
triggers.

bcc-0.4.0-3.fc28.src.rpm
csound-6.03.2-13.fc26.src.rpm
embree-2.17.0-2.fc28.src.rpm
gcin-2.8.5-2.fc28.src.rpm
libgda-5.2.2-11.fc24.src.rpm
lookup-2.1-8.fc27.src.rpm
lv2-x42-plugins-0.3.0-0.3.20170428.fc27.src.rpm
mozc-2.20.2677.102-7.fc28.src.rpm
python-thriftpy-0.3.9-5.fc27.src.rpm
qcad-3.19.1.0-2.fc28.src.rpm
zenon-0.8.2-9.fc28.src.rpm
    These are probably package bugs.
    I found e.g.
    https://github.com/iovisor/bcc/issues/1513
    https://github.com/facebook/flow/issues/5270
    https://github.com/wbolster/happybase/issues/168

ustl-2.5-4.fc27.src.rpm
    gcc8 now knows "__is_assignable" and that clashes with packages's own 
version

liblsl-1.12.0-1.fc28.src.rpm
    error: 'cerr' is not a member of 'std'
    212     std::cerr << "Error during close_if_open (thread id: " << 
boost::this_thread::get_id() << "): " << e.what() << std::endl;
    213          ^~~~
    214 /builddir/build/BUILD/liblsl-1.12.0/src/socket_utils.h:60:9: note: 
'std::cerr' is defined in header '<iostream>'; did you forget to '#include 
<iostream>'?
    so I'd think a package bug

alliance-5.1.1-11.20160506gitd8c05cd.fc28.src.rpm
    dvipdf not found; seems unrelated to gcc

arachne-pnr-0.1-0.3.20170628git7e135ed.fc28.src.rpm
    /usr/include/c++/8/bits/stl_tree.h:452:21: error: static assertion failed: 
comparison object must be invocable with two arguments of key type
    libstdc++ is more strict, see https://gcc.gnu.org/PR48101

analitza-17.12.1-1.fc28.src.rpm
grantlee-qt5-5.1.0-6.fc27.src.rpm
kdevelop-php-5.2.1-1.fc28.src.rpm
kdevelop-python-5.2.1-1.py3.fc28.src.rpm
liblxqt-0.11.1-7.fc27.src.rpm
marble-17.12.1-1.fc28.src.rpm
qt5-qtdeclarative-5.10.0-1.fc28.src.rpm
qt5-qtlocation-5.10.0-1.fc28.src.rpm
qt5-qtremoteobjects-5.10.0-1.fc28.src.rpm
renderdoc-0.91-4.fc28.src.rpm
sddm-0.17.0-1.fc28.src.rpm
spectacle-17.12.1-1.fc28.src.rpm
    internal compiler error: Segmentation fault
    https://gcc.gnu.org/PR82882
    fixed upstream and in gcc-8.0.1-0.5.fc28

sng-1.1.0-5.fc27.src.rpm
    internal compiler error: in tree_to_shwi, at tree.h:4268
    https://gcc.gnu.org/PR83896
    fixed upstream and in gcc-8.0.1-0.5.fc28

libodb-pgsql-2.4.0-8.fc27.src.rpm
libodb-sqlite-2.4.0-8.fc27.src.rpm
mp-3.1.0-14.20161124git1f3980.fc28.src.rpm
    internal compiler error: unexpected expression '(void 
(odb::details::shared_ptr<odb::pgsql::insert_statement>::*)())(0)' of kind 
cast_expr
    https://gcc.gnu.org/PR83974
    fixed upstream and in gcc-8.0.1-0.6.fc28

arpage-0.3.3-24.fc28.src.rpm
atkmm-2.24.2-5.fc27.src.rpm
bakery-2.6.3-19.fc27.src.rpm
ccgo-0.3.6.5-7.fc28.src.rpm
cclive-0.9.3-19.fc27.src.rpm
clipsmm-0.3.5-1.fc28.src.rpm
eiciel-0.9.12.1-1.fc28.src.rpm
flowcanvas-0.7.1-27.fc27.src.rpm
gconfmm26-2.28.3-14.fc27.src.rpm
gdlmm-3.7.3-10.fc27.src.rpm
gimagereader-3.2.3-3.fc27.src.rpm
glibmm24-2.54.1-1.fc28.src.rpm
gnome-system-monitor-3.26.0-1.fc28.src.rpm
gobby-0.4.13-13.fc27.src.rpm
goocanvasmm-0.15.4-18.fc27.src.rpm
goocanvasmm2-1.90.11-5.fc27.src.rpm
gparted-0.30.0-1.fc28.src.rpm
grub-customizer-5.0.6-6.fc28.src.rpm
gsmartcontrol-1.1.3-1.fc28.src.rpm
gtkglextmm-1.2.0-27.fc27.src.rpm
gtkmm24-2.24.5-4.fc27.src.rpm
gtkmm30-3.22.2-1.fc28.src.rpm
gtksourceviewmm-2.10.3-13.fc27.src.rpm
gtksourceviewmm3-3.18.0-5.fc27.src.rpm
gtkspellmm30-3.0.5-4.fc27.src.rpm
harmonyseq-0.16-24.fc27.src.rpm
jalv-1.6.0-3.fc27.src.rpm
lastfmlib-0.4.0-16.fc27.src.rpm
libgdamm-4.99.11-4.fc27.src.rpm
libglademm24-2.6.7-18.fc27.src.rpm
libgnomecanvasmm26-2.26.0-18.fc27.src.rpm
libnotifymm-0.7.0-10.fc27.src.rpm
libsexymm-0.1.9-24.fc27.src.rpm
libvtemm-0.25.0-14.fc27.src.rpm
libxml++-2.40.1-5.fc27.src.rpm
lifeograph-1.4.2-4.fc27.src.rpm
lv2-abGate-1.1.3-17.fc27.src.rpm
lv2-avw-plugins-0.0.8-14.fc27.src.rpm
lv2-ll-plugins-0.2.8-21.fc27.src.rpm
lv2-newtonator-0.6.0-11.fc27.src.rpm
lv2-triceratops-0.1.7-9.fc27.src.rpm
mate-system-monitor-1.19.1-1.fc28.src.rpm
mlpack-2.2.5-2.fc28.src.rpm
nitrogen-1.6.1-3.fc27.src.rpm
paman-0.9.4-19.fc27.src.rpm
paprefs-0.9.10-14.fc27.src.rpm
pavucontrol-3.0-10.fc27.src.rpm
pavumeter-0.9.3-19.fc27.src.rpm
repsnapper-2.4-0.5.a3.fc27.src.rpm
seq24-0.9.3-4.fc27.src.rpm
synfigstudio-1.2.1-1.fc28.src.rpm
workrave-1.10.20-1.fc28.src.rpm
xfce4-hardware-monitor-plugin-1.5.0-6.fc27.src.rpm
z3-4.6.0-1.fc28.src.rpm
    these are actually package bugs, see my earlier note.
    also see https://gcc.gnu.org/PR84012 and
    https://gcc.gnu.org/gcc-7/porting_to.html#hypothetical-instantiation

uhd-3.10.1.0-6.fc27.src.rpm
    error: cannot bind non-const lvalue reference of type 'const char*&' to an 
rvalue of type 'const char*'
    GCC 8 rejects this valid code
    https://gcc.gnu.org/PR84231
    not fixed yet

xen-4.10.0-2.fc28.src.rpm
    error: only zero initializers are allowed in section 
'.bss.page_aligned.const'
    a GCC bug, we were being too strict
    https://gcc.gnu.org/PR84237
    fixed upstream and in gcc-8.0.1-0.13.fc28

chromium-63.0.3239.108-1.fc28.src.rpm
    the nasty ABI bug I mentioned earlier, we will need to do another mass
    rebuild to see what other packages are affected.
    This is https://gcc.gnu.org/PR84286 but that should be a duplicate of
    https://gcc.gnu.org/PR84502, which was fixed upstream.
    Also see https://bugzilla.redhat.com/show_bug.cgi?id=1546255

python-mapnik-0.1-26.20170614git1635afe.fc28.src.rpm
    internal compiler error: in finish_member_declaration, at 
cp/semantics.c:3011
    https://gcc.gnu.org/PR84296
    fixed upstream and in gcc-8.0.1-0.13.fc28

casync-2-4.fc28.src.rpm
    wrong-code with -ffast-math
    https://gcc.gnu.org/PR84309
    fixed upstream and in gcc-8.0.1-0.14.fc28

hunspell-1.6.2-1.fc28.src.rpm
    wrong-code with optimizing strlen
    https://gcc.gnu.org/PR84339
    fixed upstream and in gcc-8.0.1-0.14.fc28

scantailor-0.9.11.1-19.fc27.src.rpm
    error: 'mcalc::Mat<T>::Mat(mcalc::AbstractAllocator<T>*, const T*, int, 
int) [with T = double]' is private within this context
    rejected since https://gcc.gnu.org/r255780
    most likely a package bug

asio-1.10.8-6.fc27.src.rpm
mame-0.193-1.fc28.src.rpm
tomahawk-0.8.4-17.fc27.src.rpm
    error: ambiguous overload for 'operator=='
    https://gcc.gnu.org/PR84283
    fixed upstream and in gcc-8.0.1-0.13.fc28

systemd-bootchart-233-1.fc28.src.rpm
    see https://bugzilla.redhat.com/show_bug.cgi?id=1543912
    a bug, but not in GCC probably

arts-1.5.10-36.fc27.src.rpm
bliss-0.73-5.fc27.src.rpm
ETL-1.2.1-1.fc28.src.rpm
nqc-3.1.7-21.fc27.src.rpm
qlandkartegt-1.8.1-14.fc28.src.rpm
stratagus-2.2.7-11.fc27.src.rpm
tcpreen-1.4.4-16.fc27.src.rpm
xmoto-0.5.11-13.fc27.src.rpm
    error: unable to find string literal operator
    it needs a space before __FILE__
    it's invalid code, although GCC 7 used to give a warning not an error
    https://gcc.gnu.org/r254443 started rejecting ""__FILE__""
    Jon opened https://gcc.gnu.org/PR84517, we might downgrade this to
    a warning again.

deepin-api-3.1.14-2.fc28.src.rpm
    undefined reference to symbol 'g_time_zone_adjust_time'
    I don't think it's a gcc bug.

cargo-0.24.0-1.fc28.src.rpm
containerd-1.0.0-1.fc28.src.rpm
deepin-dbus-generator-0.6.6-1.fc28.src.rpm
firefox-58.0.2-1.fc28.src.rpm
krb5-1.16-2.src.rpm
libguestfs-1.37.35-2.fc28.src.rpm
maxima-5.41.0-4.fc28.src.rpm
netcdf-4.4.1.1-6.fc27.src.rpm
nvml-1.3-3.fc27.src.rpm
proftpd-1.3.6-10.fc28.src.rpm
python33-3.3.7-2.fc28.src.rpm
smb4k-2.0.2-1.fc28.src.rpm
    I'm not sure about these failures, but they don't seem to be GCC bugs.
    firefox has same issue as cargo, they built fine in koji
    proftpd: timeouts in tests, but in koji it's fine
    maxima: doesn't invoke gcc/g++/gfortran at all?
    python33: two test fail:
      smtplib.SMTPServerDisconnected: Connection unexpectedly closed
    networking issues in mock?
    krb5: keyctl_join_session_keyring: Operation not permitted
    probably a network issue again

ahven-2.6-9.fc28.src.rpm
gela-asis-0.3.2-9.fc27.src.rpm
PragmARC-20130728-14.fc27.src.rpm
zeromq-ada-2.1.0-23.24032011git.fc27.src.rpm
zlib-ada-1.4-0.18.20120830CVS.fc27.src.rpm
  gnatmake: project files are no longer supported by gnamake; use gprbuild 
instead
  Ada; didn't investigate

postgresql-10.1-4.fc28.src.rpm
xfsprogs-4.14.0-1.fc28.src.rpm
    glibc gained copy_file_range, a declaration is in unistd.h
    so we get conflicting declarations
    not gcc related

claws-mail-3.15.1-5.fc28.src.rpm
    A configure test fails: can't find encrypt() with -lcrypt.
    In F27, it's provided by libcrypt-nss but that isn't in rawhide.
    not gcc related

PyPAM-0.5.0-33.fc28.src.rpm
    ImportError: No module named PAM
    my notes say "missing -ldl" but I'm not actually sure what that meant

hyperscan-4.6.0-1.fc28.src.rpm
ntop-5.0.1-14.fc28.src.rpm
orthanc-1.3.0-4.fc28.src.rpm
SimGear-2017.3.1-1.fc28.src.rpm
tellico-2.3.12-4.fc27.src.rpm
    No matching package to install: 'tcp_wrappers-devel'
    and similar.  Not gcc related.

arm-none-eabi-gcc-cs-7.1.0-5.fc27.src.rpm
astrometry-0.73-1.fc28.src.rpm
clang-5.0.1-2.fc28.src.rpm
esc-1.1.1-1.fc27.src.rpm
gdcm-2.6.5-19.fc28.src.rpm
icecat-52.5.3-3.fc28.src.rpm
InsightToolkit-4.9.1-7.fc27.src.rpm
java-9-openjdk-9.0.1.11-4.fc28.src.rpm
llvm3.9-3.9.1-11.fc27.src.rpm
openblas-0.2.20-3.fc28.src.rpm
pcl-1.8.0-13.fc28.src.rpm
QuantLib-1.10.1-1.fc28.src.rpm
supertuxkart-0.9.3-2.fc28.1.src.rpm
texlive-2016-39.20160520.fc28.src.rpm
vtk-7.1.1-9.fc28.src.rpm
warsow-2.1-7.fc27.src.rpm
    these packages require a huge amount of memory and none of my builder boxes
    had enough memory to build these.

gqrx-2.9-1.fc28.src.rpm
gr-air-modes-0-0.56.20160831git3bad1f5d.fc27.src.rpm
gr-iqbal-0.37.2-27.fc27.src.rpm
gr-osmosdr-0.1.4-6.20170221git2a2236cc.fc27.src.rpm
gr-rds-0-0.30.20150513git201f32b.fc27.src.rpm
kdepim-runtime-17.12.1-1.fc28.src.rpm
mongo-c-driver-1.9.2-2.fc28.src.rpm
sumwars-0.5.8-13.fc27.src.rpm
teamgit-0.0.12-21.20130626.fc27.src.rpm
vegastrike-0.5.1-31.r1.fc27.src.rpm
xsd-4.0.0-20.fc28.src.rpm
    nothing provides libboost_system.so.1.64.0()(64bit) needed by 
gnuradio-3.7.11-7.fc28.x86_64
    not gcc related

COPASI-4.22.170-5.fc28.src.rpm
octave-audio-1.1.4-18.fc26.src.rpm
octave-communications-1.2.1-5.fc26.src.rpm
octave-control-3.0.0-3.fc26.src.rpm
pfstools-2.0.6-3.fc27.src.rpm
qtoctave-0.10.1-19.fc23.src.rpm
R-affy-1.54.0-3.fc27.src.rpm
R-msm-1.6.4-3.fc27.src.rpm
vfrnav-20160429-11.fc28.src.rpm
    libgfortran bumped SONAME again, and clearly not everything has been
    rebuilt yet.  It might be as of now.

ardour4-4.7.0-9.fc28.src.rpm
    --freedesktop requires itstool > 2.0.0 to translate files.
    unsure, but probably failed with GCC 7 too

gcl-2.6.12-7.fc26.src.rpm
    Error: ERROR "The assertion !clear_protect_memory(memory) on line 580 of 
sfaslelf.c in function fasload failed"
    unsure, but probably failed with GCC 7 too

lordsawar-0.3.0-4.fc25.src.rpm
    error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
    unsure, but probably failed with GCC 7 too

SDL_sound-1.0.3-19.fc27.src.rpm
    https://github.com/Homebrew/legacy-homebrew/issues/40872
    unsure, but probably failed with GCC 7 too

openfst-1.6.3-1.fc27.src.rpm
saga-2.2.7-9.fc28.src.rpm
    configure: error: cannot import Python module "distutils".
    Please check your Python installation. The error was:
    DEPRECATION WARNING: python2 invoked with /usr/bin/python.
    seems to be about the python2 to python3 switch.  Doesn't seem to be
    gcc related at all.

rusers-0.17-87.fc27.src.rpm
samba-4.7.4-0.fc28.src.rpm
    rpcgen not found
    glibc related?

PyMca-4.7.3-8.fc26.src.rpm
    fatal error: xlocale.h: No such file or directory
    xlocale.h has been renamed upstream in glibc. See:
    Rename xlocale.h to bits/types/__locale_t.h
    
https://sourceware.org/git/?p=glibc.git;a=commit;h=f0be25b6336db7492e47d2e8e72eb8af53b5506d
    
https://sourceware.org/git/?p=glibc.git;a=commit;h=af85385f311c574590381f7897461643f8a2fe6f

NetworkManager-ssh-1.2.7-1.fc28.src.rpm
NetworkManager-strongswan-1.4.2-1.fc28.src.rpm
    not a GCC 8 problem; see
    <https://github.com/danfruehauf/NetworkManager-ssh/issues/74>

libsbml-5.16.0-2.fc28.src.rpm
libsedml-0.4.3-6.fc28.src.rpm
R-affyio-1.46.0-3.fc27.src.rpm
R-backports-1.1.2-1.fc28.src.rpm
R-base64enc-0.1.3-1.fc28.src.rpm
R-biglm-0.9.1-10.fc27.src.rpm
R-Biobase-2.36.2-3.fc27.src.rpm
R-bitops-1.0.6-7.fc27.src.rpm
R-BufferedMatrix-1.40.0-3.fc27.src.rpm
R-BufferedMatrixMethods-1.40.0-3.fc27.src.rpm
R-Cairo-1.5.9-2.fc28.src.rpm
R-caTools-1.17.1-6.fc27.src.rpm
R-commonmark-1.4-1.fc28.src.rpm
R-curl-3.0-1.fc28.src.rpm
R-digest-0.6.12-3.fc27.src.rpm
R-expm-0.999.2-3.fc27.src.rpm
R-filehash-2.4.1-1.fc28.src.rpm
R-GenomicAlignments-1.12.1-3.fc27.src.rpm
R-GenomicRanges-1.28.3-3.fc27.src.rpm
R-highlight-0.4.7.1-4.fc27.src.rpm
R-htmltools-0.3.6-2.fc28.src.rpm
R-httpuv-1.3.5-2.fc28.src.rpm
R-IRanges-2.10.1-3.fc27.src.rpm
R-jpeg-0.1.8-3.fc28.src.rpm
R-jsonlite-1.5-5.fc28.src.rpm
rkward-0.6.5-11.fc28.src.rpm
R-littler-0.3.3-1.fc28.src.rpm
R-maanova-1.46.1-3.fc27.src.rpm
R-markdown-0.8-3.fc28.src.rpm
R-matrixStats-0.52.2-3.fc27.src.rpm
R-mime-0.5-1.fc28.src.rpm
R-multtest-2.32.0-3.fc27.src.rpm
R-pbdZMQ-0.2.6-4.fc28.src.rpm
R-plyr-1.8.4-4.fc28.src.rpm
R-png-0.1.7-3.fc28.src.rpm
R-preprocessCore-1.38.1-3.fc27.src.rpm
R-qtl-1.41.6-3.fc27.src.rpm
R-Rcpp-0.12.14-1.fc28.src.rpm
R-RCurl-1.95.4.8-3.fc27.src.rpm
R-reshape2-1.4.3-1.fc28.src.rpm
R-RInside-0.2.14-5.fc28.src.rpm
R-rlecuyer-0.3.4-3.fc27.src.rpm
R-ROC-1.46.0-5.fc27.src.rpm
R-RODBC-1.3.15-3.fc27.src.rpm
R-Rsolid-0.9.31-22.fc27.src.rpm
R-RSQLite-1.1.2-4.fc27.src.rpm
R-rtracklayer-1.36.3-3.fc27.src.rpm
R-S4Vectors-0.14.3-3.fc27.src.rpm
R-sp-1.2.5-4.fc28.src.rpm
R-statmod-1.4.20-7.fc27.src.rpm
R-testthat-1.0.2-3.fc27.src.rpm
R-tikzDevice-0.10.1-1.fc28.src.rpm
R-uuid-0.1.2-2.fc28.src.rpm
R-V8-1.5-2.fc28.src.rpm
R-wavethresh-4.6.8-3.fc27.src.rpm
R-XML-3.98.1.7-3.fc27.src.rpm
R-XVector-0.16.0-3.fc27.src.rpm
R-yaml-2.1.16-1.fc28.src.rpm
    these all say exec: INSTALL: not found
    Certainly doesn't seem to be GCC 8 related.

        Marek
_______________________________________________
devel mailing list -- devel@lists.fedoraproject.org
To unsubscribe send an email to devel-le...@lists.fedoraproject.org

Reply via email to