Regarding my prior message, I just found this bug report at Adobe regarding camera not working with FlashPlayer on Linux, but it says that FlashPlayer 10 should resolve the problem.    Apparently it didn't on the XO.


-------- Original Message --------
Subject: Problems with Adobe Flash player on the XO.
Date: Thu, 01 Jan 2009 14:20:38 -0800
From: Stanley Sokolow <>
To: Nirbheek Chauhan <>
References: <>


I'm having problems:  Adobe FlashPlayer doesn't detect the XO's built-in 
webcam so it can't transmit video out to the Internet on Flash-enabled 
web sites, and the Adobe Flash player on the XO freezes the popup 
right-click control panel.   Gnash didn't work at all with a Flash-based 
web site we're interested in, so I went to the real FlashPlayer, latest 

I've been lurking here watching the comments on Gnash versus Flash while 
I tried to get my wife's XO playing nicely with a Flash-based RIA (rich 
internet application) site called .    (That's pronounced 
like "view".)     Vyew is a collaborative whiteboard application with 
video, voice, and text chatting features in addition to the 
whiteboard.   By whiteboard, I mean that several users can connect to 
the same page and collaborate on drawing sketches and typing text on the 
same screen, which is visible to all of the connected people.    They 
can also activate their camera and microphone (if they exist) to carry 
on two-way conversations like Skype.   She wants to use this for a 
remote tutoring activity where she interacts with students about math 
problems.    We tried to get Paint and Colors activities to play nicely 
with various Sugar emulators (LiveCD, Sugar on Ubuntu, Sugar on Windows 
Vista) but they all had various problems seeing (presence detection) or 
collaborating.  So we found this web site, Vyew.   The Vyew site didn't 
load the Flash content on the web page with Browse and Gnash, so I 
installed the real Adobe Flash player on the XO.  We have been largely 
successful with Vyew and Adobe FlashPlayer on the XO.  Both computers 
can see each other's drawings collaboratively on the same page, but we 
ran into one problem that relates to Flash on the XO.  

The XO browser can see the webcam video stream from our Dell laptop 
running Vyew on the Dell's Vista browsers (MS IE & Firefox) and can hear 
the audio stream from the Dell, but I can't get Flash to activate the 
XO's camera.    When I right-click on the Flash box in the web page, the 
Flash popup menu appears.   I click the "settings" item.  Adobe Flash 
Player control panel pops up as it should, but it is just frozen.   I 
can't get it to flip to the other tabs to set the camera & microphone 
permissions.   In fact, the panel won't even quit when I click the Close 
button.   Nothing gets rid of it except reloading or leaving the web 
page.   This was while running on the XO's Browse activity.   I thought 
that maybe Opera for the XO would do better.  No luck.   Opera as 
installed from the instructions does not even play 
the Flash on the Adobe web site: , 
nor any other Flash embedded in a web page.   All that Opera shows is a 
gray rectangle where the Flash should be, no text saying to click to 
play the Flash.   This is apparently a problem of Opera not interacting 
well with FlashPlayer, because the Opera plugin directories point to the 
very same plugin program file by symbolic linkage, so it's not a bad 
plugin file -- the Adobe plugin plays the Flash .swf embedded element 
with Browse, just not perfectly, but Opera doesn't play it at all.

I submitted a comment to the Opera programmer who maintains the Opera 
blog about the OLPC version, but that blog has had very little activity 
in the past year so I'm not hopeful of any results from the Opera 
people.    Has anyone here tried to run a recent release of Opera on the 
XO, not the very old version that was customized for the XO according to 
our wiki?

For the record, here are the various versions I'm running:  XO has build 
767 of Sugar, the XO is one recently received from the G1G1 program 
through Amazon, the FlashPlayer is the one recommended on the page: 
, the "about" Flash page reports the correct release 10,0,15,3 and so 
does the README in the flash-plugin folder on the XO, and uname reports 
that my XO's Linux version is 2.6.25-20080925.1.olpc.f10b654367d7065.

Even without the 2-way video streaming, is a nice 
application for collaboration over the Internet.  Try it.

Stan Sokolow

Devel mailing list

Reply via email to