the config.log reports there is no /usr/include/sys/statfs.h on your system.

on my system, this file exists and is provided by the msys2-runtime-devel file,

so the first steps are to check this package is installed and if not, install it.

note I ran pacman -Syu a few times to make sure my system is up to date.



On 10/22/2018 5:13 PM, Santiago Serebrinsky wrote:
Thanks Dmitry.

I was aware of the two links posted...

[1]: It dates from 2016, and the issue with statfs/stavfs persists.
I wouldn't know how to "submit a pull request with a PKGBUILD for the package", and from the post I did not understand if that is like a "feature request", or if that provides a version that lets me move forward immediately. In the latter case I would certainly do it.

[2]: To get a "real" linux (Ubuntu) under Win10 I could get WSL (as you indicate) or another Virtual Machine (e.g., vbox). Both require admin rights, so it would be a longer process (if possible at all) in my corporate environment.

On Sun, Oct 21, 2018 at 9:31 PM Dmitry N. Mikushin < <>> wrote:

    MSYS2 is known for not supplying statfs/statvfs, which are
    practically meaningless in a Windows-based environment, see e.g. [1]

    Yet, both calls do not seem to be critical for MPI internals, thus
    one can potentially develop patches to turn them into an optional
    feature within OpenMPI.

    If you are looking for quick OpenMPI solution on Windows, you may
    want to look into Ubuntu terminal for Windows, where OpenMPI works


    пн, 22 окт. 2018 г. в 0:52, Santiago Serebrinsky
    < <>>:

        Hi all,

        I am using Msys2 from PortableApps under Win10. More precisely,

        |$ uname -a MSYS_NT-10.0-WOW Galapagos 2.11.1(0.329/5/3)
        2018-09-10 13:25 i686 Msys |

        I mean to install openmpi. Since I found no pre-built package
        (I would love to have it!), I downloaded openmpi-3.1.2.

        After having problems with Fortran (posted in another thread),
        I tried

        |./configure --prefix=$HOME/usr/local --disable-mpi-fortran |

        In this case configure went somewhat further than before, but
        I got later the error

           configure: WARNINGS: neither statfs() and statvfs() were found
           error: Cannot continue

        devel mailing list <>

    devel mailing list <>

devel mailing list

devel mailing list

Reply via email to